IW STi Forum banner

2121 - 2125 of 2125 Posts

·
Super Moderator
Joined
·
8,514 Posts
Discussion Starter #2,121
Dropped my S2000 off at my buddies house, who actually made the aero for my car (Zebulon MSC), to have some bolt-in heat shielding fabbed up around the turbo and my splitter installed (since it was there and I hadn't done it). Looking to get it out to Ice Cream Cruise in Omaha in less than 2 weeks, then drop it off to get the damage fixed in the rear. When I pick it up... Straight to the track!

 

·
Super Moderator
Joined
·
8,514 Posts
Discussion Starter #2,122
I took the car out to Omaha for 1320 Video's Ice Cream Cruise, as well as had the customer car with the gen 2 GTX3582. Had a pretty good time and I'm looking to get it on track in less than two weeks.




I did run the roll races... I was at wastegate boost all day as I forgot to plug in the harness to the ECU after wiring for the AEM dash. The AEM v2 was being selective on internal logging, so I was only able to pull one log from all my runs. It didn't do too bad considering the 6-7 PSI of boost. I was able to run neck and neck with my buddies bolt-on C6... Still hoping a video shows up.

This was against an E30 tuned Focust ST:

https://www.youtube.com/v/XIqu64BAo7Y


The STi did pretty well. We ended up running a bunch of passes with it and even walking a Yamaha R1 on the freeway the night before. :) We tried to run the Boostedboiz Hondaru a couple times, but my guy missed a gear the first time and 2-1 shifted the second. Motor seems fine and when we tried for a 3rd run, they closed down the track (so if you see that video...)

This was against PFI's AWD, sequential Civic:
https://www.youtube.com/v/lamUOUptq30

I need to get a better quality video, but it was a pretty even race against a bolt-on and meth ZR1 Corvette, but here is a run vs a nitrous C6:
https://www.youtube.com/v/Ebrvywr8KRA




Finally, the S2000 has a splitter mounted.
 

·
Super Moderator
Joined
·
8,514 Posts
Discussion Starter #2,123
Got the car out to a NASA event at High Plains Raceway this weekend. I ran HPDE 4 as I knew I'd be rusty... And I was. This was the first time I had the car out on the track in 4.5 years, so I had to get back into the groove.... I definitely did not pickup where I left off. I ran wastegate spring for this event, which was between 4.5-5 PSI. I was on 4.5 year old RE71R's and it was about 88F and 5k ft above sea level. I also needed to bleed the brakes, as It's been nearly 5 years... But they worked fine, just a touch squishy.
:)


I was worried about heat in the turbo area, so I did as much shielding as I could and picked up a fire extinguisher. The only issues I had where that I had a radiator vent hose come loose, which didn't happen on track, and my V-band clamp loosen up on the turbo to downpipe. The first time I went out, open lapping on Friday, I saw my OEM temp gauge start moving up several bars, making me nervous, so I backed off and did some easier laps. Once off track, I pulled the log off the ECU and it showed a max coolant temp of 201. Knowing that AEM internal logging is hit or miss, I strapped my laptop in the passenger seat for the first session on Saturday, which is what I am looking at in the video. The data matched what I had seen with the internal log, so I didn't pay much attention to the OEM gauge.

My max temps all weekend were:

Coolant - 203F
Oil - 235F
Air temp on track - 105F


Data from the back straight:


First session on Saturday, checking my laptop for true coolant temps: Again, very rusty and this was the first time out with the turbo and aero.













I also had a customer S2000 out, who placed 1st in TT1 and got the lap record!



60699
 

·
Premium Member
Joined
·
14,732 Posts
S2000 is looking awesome! I have to get mine up to a turbo spec!
 

·
Super Moderator
Joined
·
8,514 Posts
Discussion Starter #2,125
S2000 is looking awesome! I have to get mine up to a turbo spec!

Thanks! These don't need much boost to wake up. I'm running 4.5 PSI for now and getting caught up on my driving again. I've now done 3 track days with this... And NO maintenance in between! This past Saturday, I put 120 track miles on the car and I wasn't taking it easy. :)



And the car is really, really quiet. Aside from the turbo cutting down exhaust noise, I only have a single, 3" straight-thru muffler.

 
2121 - 2125 of 2125 Posts
Top