IW STi Forum banner

141 - 160 of 1253 Posts

·
Registered
Joined
·
815 Posts
Re: Willub's 04 STi: Oil pressure issue is fixed, but...

Glad you got your wheels ordered! Those guys over at AutoRnD are great!
 

·
Registered
Joined
·
2,512 Posts
Re: Willub's 04 STi: Oil pressure issue is fixed, but...

Can you describe the noise a bit more?

My understanding is that if a bearing goes you'll find copper particles in the filter, which you should cut open. Also, what makes you think it's a wrist pin? In order for a wrist pin to slide out of place, one of the circlips would need to be removed, no?

PS: Heuberger Subaru sells shortblocks for $1645. Pick one up, drop in a CP piston kit yourself, clean your heads, and you're good to go! :D
 

·
Registered
Joined
·
1,624 Posts
Discussion Starter #143 (Edited)
Re: Willub's 04 STi: Oil pressure issue is fixed, but...

This is what it sounded like for about a minute, then it slowly went away. I'm going to cut my old filter open tonight.
https://www.youtube.com/watch?v=1tof3Ij827Y

Here it is starting up this morning. Can't hear anything out of the ordinary. Sorry for the shakiness, it's cold out and this camera weighs nothing :lol:


I don't know what's going on. I thought it was going to be temperature related, but it's not. Maybe there was enough oil getting pumped up to the rod bearing but not enough to slosh up to the wrist pin, and mind you I drove it for about 4 hours on the highway at 3k rpm the night before the noise occured. All I know is that it was making a bad noise like in the link up above and now it seems fine. :banghead:

Maybe my engine was built by unicorns and it fixed itself!
 

·
Registered
Joined
·
1,624 Posts
Discussion Starter #144 (Edited)
Re: Willub's 04 STi: Oil pressure issue is fixed, but...

Can you describe the noise a bit more?

My understanding is that if a bearing goes you'll find copper particles in the filter, which you should cut open. Also, what makes you think it's a wrist pin? In order for a wrist pin to slide out of place, one of the circlips would need to be removed, no?

PS: Heuberger Subaru sells shortblocks for $1645. Pick one up, drop in a CP piston kit yourself, clean your heads, and you're good to go! :D
I'm thinking there was somehow a lack oil getting to it, creating unusual wear or it was just dry and now the oil is just quieting it down. But the noise isn't returning so I really don't know.

That actually sounds like a good idea! I might just do that as a back up motor for when this one does inevitably go. Yours just has CP drop ins right? How's the noise factor?
 

·
Registered
Joined
·
90 Posts
Re: Willub's 04 STi: Oil pressure issue is fixed, but...

Might be a long shot but here at the shop we had a 4.6 3v have a similar sound until warmed up and it was the variable cam timing. On the ford had to replace the cam gear phaser. The sti uses the avcs, wonder if that is messing up. Have you ever cleaned the screens in the banjo nut for the oil going to the avcs unit on top of the heads?
 

·
Registered
Joined
·
1,624 Posts
Discussion Starter #146
Re: Willub's 04 STi: Oil pressure issue is fixed, but...

I made a thread in the 2.5 factory engine section and it has been said that it could have been the buckets. Like I said earlier, maybe there was a lack of oil getting to a head and creating the noise. This makes sense as the noise is not returning and would be awesome if that's all it was. If I don't find any metal in the oil filter tonight I'm going to forget that I ever heard this noise
 

·
Registered
Joined
·
1,624 Posts
Discussion Starter #147
Re: Willub's 04 STi: Oil pressure issue is fixed, but...

Might be a long shot but here at the shop we had a 4.6 3v have a similar sound until warmed up and it was the variable cam timing. On the ford had to replace the cam gear phaser. The sti uses the avcs, wonder if that is messing up. Have you ever cleaned the screens in the banjo nut for the oil going to the avcs unit on top of the heads?
I actually removed the one from the passenger side head as I'm using braided stainless line now since I swapped my turbo. I don't know too much about the avcs on this car, I guess I'll do some research. Thanks for the suggestion
 

·
Registered
Joined
·
1,374 Posts
Re: Willub's 04 STi: Oil pressure issue is fixed, but...

If I don't find any metal in the oil filter tonight I'm going to forget that I ever heard this noise
I tried to take that attitude as well... Look where I ended up LOL. I hope it turns out to be OK but I would prepare for the worst.
 

·
Registered
Joined
·
1,624 Posts
Discussion Starter #150
Re: Willub's 04 STi: Oil pressure issue is fixed, but...

It might be a bit of a pain, but I would definitely remove the AVCS screens if you have a chance. If any bits get into the system they'll get caught by the screens, but then that component may suffer oil starvation. (if the screen gets clogged)
Is it just the two on the passenger side head? I've never taken a close look at the drivers side.

I tried to take that attitude as well... Look where I ended up LOL. I hope it turns out to be OK but I would prepare for the worst.
:lol: yeah I know. If it happens it happens. Anything can fail at any moment really. I think it will be alright, I'm becoming convinced it was an issue with the AVCS

I cut open my oil filter and there are no signs of bearing failure or any metal. I'll be hooning around in the snow tomorrow and Saturday. I'm gonna beat the snot out of it before I drive it three hours up to the rally x event. I'd rather something go horribly wrong down here where I get free towing :D
 

·
Registered
Joined
·
1,624 Posts
Discussion Starter #152 (Edited)
Re: Willub's 04 STi: Oil pressure issue is fixed, but...

Yeah it looks like there are two banjo bolts connected by a small hard line right up front. They look pretty easy to get to so I may check it out tonight.

I took a look underneath my car this morning and I don't see any oil leaks, sweet! I lost the crush washer in my drain pan and forgot to get one from the dealer while I was there. I just slapped some super black RTV on the base of the bolt where the washer normally is and no leaks!
 

·
Registered
Joined
·
1,624 Posts
Discussion Starter #153
Re: Willub's 04 STi: Oil pressure issue is fixed, but...

Plow attachment :lol: If my snow tires weren't bald I would have made it out first shot :D



The total so far for my area is 27 inches :eek:
 

·
Registered
Joined
·
1,374 Posts
Re: Willub's 04 STi: Oil pressure issue is fixed, but...

Gonna need a new radiator if you keep that up LOL.
 

·
Registered
Joined
·
1,624 Posts
Discussion Starter #156 (Edited)
Re: Willub's 04 STi: Oil pressure issue is fixed, but...

Got back from the rally x event about 4 hours ago. It was pretty awesome. We got about 20 runs total since there were only 27 people. Oh and my engine is fine. It survived the 6 hour round trip and 20 runs of rally X :tup:

This is one of my slowest runs, but I had to upload it cause of how close I got to the hairpin cone. I always got within a foot or two of it, except a couple times where I totally blew it, but this time it looks like I got within an inch from it. E-brake FTW :D


The course was glare ice underneath all of the snow except in a couple spots, so it was pretty tricky to get used to. I didn't go in to boost once :lol: My snow tires with 25% of their life left still did decent. Me and my friend swapped cars for one run and I beat him my first time out with it :D I know all too well what that's like from having a co-driver at autocross who sometimes beats me though :lol: He was amazed at how floaty my car was, it would not turn in on this stuff at all. It required lots of blipping and e-brake to get it to go

For the guys who race at Devens, this is my friend's new car. You may recognize it!
 

·
Registered
Joined
·
1,624 Posts
Discussion Starter #157
Re: Willub's 04 STi: RallyX was sweet!

Here's some more pictures from the event. Thanks to daggerslade media and frog racing







 

·
Registered
Joined
·
1,624 Posts
Discussion Starter #159
Re: Willub's 04 STi: RallyX was sweet!

That's not the SoloRu behind that wall of snow is it?
It sure is! My friend bought it off Neil back in December I think. My friend came back home for thanksgiving (He lives in michigan) and I mentioned the car and how it was for sale. He became pretty interested in it and I ended up going up to NH to test drive it and check it out for him. He bought it without ever seeing it in person lol. It's now being turned into a dedicated rally cross car.
 
141 - 160 of 1253 Posts
Top