IW STi Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
So Just got the stage 3 1050x (no flex-fuel) kit for my 2015 wrx sti. Currently on the OTS normal wastegate v400 map from cobb, but about to go get it pro tuned. But ever since I got the kit in it had felt slower, the petal feels lazy and the car just does not want to pull as hard. Every time I do a pull it will hit a 10-1 AFR, but at idle it will stay around 14.5 to 14.6. and no cel. And I have noticed occasionally it will want to stumble under load about 4k rpm and if I left of hard it bucks the car about 3 times. Any ideas? MAF? Coil packs? Spark plugs?
 

·
Registered
SWP 2012 GR Hatch
Joined
·
503 Posts
While fresh coils and plugs are ideal for the best pro tune, it really sounds like the car just isnt set right.
i’d either avoid driving or drive carefully/ slow until u can get it tuned properly
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
Thanks yall, I am planning to go to a shop out of Albuquerque sometime after Christmas, was just wondering if there was something I needed to get taken care of beforehand.
 

·
Super Moderator
Joined
·
9,004 Posts
 

·
Registered
Joined
·
20 Posts
So Just got the stage 3 1050x (no flex-fuel) kit for my 2015 wrx sti. Currently on the OTS normal wastegate v400 map from cobb, but about to go get it pro tuned. But ever since I got the kit in it had felt slower, the petal feels lazy and the car just does not want to pull as hard. Every time I do a pull it will hit a 10-1 AFR, but at idle it will stay around 14.5 to 14.6. and no cel. And I have noticed occasionally it will want to stumble under load about 4k rpm and if I left of hard it bucks the car about 3 times. Any ideas? MAF? Coil packs? Spark plugs?
I am pro tuned and that’s my idle AFR (14.5) and wot is 11.3. It sounds like your leaning out at higher RPM.
 
1 - 7 of 7 Posts
Top