IW STi Forum banner

21 - 40 of 314 Posts

·
Registered
Joined
·
148 Posts
Awesome tread to start, OK..
At 2500 miles No problemo. EXCEPT for the" Vibrating " Homelink rear view mirror
> Cobb AP stage 2 pro tune By HB SPEED
> 299 whp, 321 ft -lb torque whooooo!!! i I lOVE IT
Thank you JON and STAFF
 

·
Registered
Joined
·
3,528 Posts
No problems with mine, I bought it at 9500 and I have it at 13000 still runs like a champ. The only thing I absolutely hate is the door and seatbelt chimes. x(
Well then, consider me your savior. Put your car onto the setting before ignition where you have everything except the motor running.

Then, very quickly, unplug and replug your seat belt about 20 times, and then turn the car off fast and you should be chime-less from there on out. If you want it back, just do the same process.


Now, my input:

No major problems @ ~6000 miles.

  • Synthetic Royal Purple since 1300miles.
  • Recall reflash after 2 weeks of ownership.
  • Stage 1 a month-ish later.
  • Protune stage 2 @ around 3300miles -> ~6000miles.
Minor issues:

  • One rock chip on the front of the hood.
  • An idiot directed me into a curb and nicked 1 rim.
  • Car refused to start today b/c of the insane cold the first attempt. 2nd try worked but it struggled, I pressed the accelerator down a bit to get it going.
  • Squeaky trunk cover. Solution=remove it b/c I don't use it.
  • Inside door material likes to get marks... from EVERYTHING including your knuckles.
 

·
Registered
Joined
·
346 Posts
5700 miles now, 4 advanced run group track events, and still not a rattle nor mechanical issue. Am very happy with the car thus far
 

·
Registered
Joined
·
222 Posts
05, bought new. Have been autox ing it since 960 miles on it. Was daily driver until 2008. Now if a toy. I have had nothing Major that I did not cause. I had a loose bolt on my drivers seat. And the astrut clunk, but that could have been easily caused by the springs I installed.

It creaks, and there is a bunch of rattles here and there, but I have replaced a good amount of bushings, so that is to be expected. My experience would easily put me in another subaru down the road consider the amount of abuse I have dished out on this car.
I am glad your happy with your GD STI, but this thread is for GR/08,09 STI;s:D
I have a little over 600 miles, no issues here! The car seems a lot more solid/better built then my old 07, which started to have rattles driving home from the dlr when it was new.
 

·
Registered
Joined
·
212 Posts
No problems at all. 4,500 miles (Crawford Stage 2 @ 1000 miles). Now the car sits at Crawford Performance for a 35r FMIC upgrade and suspension...can 't wait!
 

·
Premium Member
Joined
·
4,121 Posts
That would be me, zero problems.....
 

·
Registered
Joined
·
2,567 Posts
People who say they have no rattles are deaf or lying. :p

Mostly it's just the fact that people have different tolerances and sensitivities to these things. I hear rattles in my car whereas my friends don't unless I REALLY point them out. Still a great car, just you sometimes need to crank the stereo!
 

·
Registered
Joined
·
98 Posts
Discussion Starter #32
Awesome feedback guys:tup:

I was thinking it might also be interesting to post what octane fuel you are running.
 

·
Registered
Joined
·
223 Posts
22,000 miles, been stage 2 for 20,000. drive the crap outta it. love it. runs like a top. Love it maybe more than i could love my own child (i dont have kids).
 

·
Registered
Joined
·
223 Posts
10,000 miles, no major issues. Wear and tear on the interior only issues. Cobb Stage 2 for about the last 6K, stage 1 for the last 9K.
 

·
Registered
Joined
·
194 Posts
09, 1700kms, completed break in, full synethic royal purple 5w30 just added. Hesitation and stumble around 4-5400rpm when full throttle is applied. AP should be stock with this car :(...The tune with these cars is not considered a "problem" anymore if no one decides to fix it.
 

·
Registered
Joined
·
3,338 Posts

·
Registered
Joined
·
167 Posts
Well then, consider me your savior. Put your car onto the setting before ignition where you have everything except the motor running.

Then, very quickly, unplug and replug your seat belt about 20 times, and then turn the car off fast and you should be chime-less from there on out. If you want it back, just do the same process.


Now, my input:

No major problems @ ~6000 miles.

  • Synthetic Royal Purple since 1300miles.
  • Recall reflash after 2 weeks of ownership.
  • Stage 1 a month-ish later.
  • Protune stage 2 @ around 3300miles -> ~6000miles.
Minor issues:

  • One rock chip on the front of the hood.
  • An idiot directed me into a curb and nicked 1 rim.
  • Car refused to start today b/c of the insane cold the first attempt. 2nd try worked but it struggled, I pressed the accelerator down a bit to get it going.
  • Squeaky trunk cover. Solution=remove it b/c I don't use it.
  • Inside door material likes to get marks... from EVERYTHING including your knuckles.
Thanks for the info, I think i remember reading that now in another thread but I will try it tomorrow for sure :D
 
21 - 40 of 314 Posts
Top