IW STi Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
236 Posts
Discussion Starter · #1 · (Edited)
My build date on my car says 01/06, can anyone confirm on wether or not for sure if i have the old style 05 mounts or the new style 06 ones? I have searche around and some people have said they started putting the 05's on 12/05 but im still not sure. Can anyone help me out here...

EDIT 9/27 - I'm pretty sure the ones I have are the updated ones from other pics i've seen but not sure. In the 2nd pic it looks like the part with the bolt on it that actually mounts to the car is black, but its actually silver like in the 1st pic, just bad lighting.



 

·
Registered
Joined
·
1,510 Posts
I think the first batch in 06 have rubber in the middle with plastic mounts. The later ones have rubber in the middle and steel mounts.

my 06 was built June 05 so I don't even have to look:tdown:

Just climb under and look.....youll be able to tell pretty quickly what you have.
 

·
Registered
Joined
·
236 Posts
Discussion Starter · #10 ·
Turninconcepts.com said:
BTW, take a look at this thread:

http://www.iwsti.com/forums/showthread.php?t=63407

Since from what I can tell you have the square top you should be good.
Yeah the pics are really scrappy, they are from my cell phone. But i can tell you the mounts are square top, not circle top. I'm pretty sure i lucked out. woohoo!:D
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top