IW STi Forum banner
1 - 4 of 4 Posts

Registered
Joined
93 Posts
Discussion Starter · #1 ·
So maybe? duhh well listen to this load of crap. my CEL came on(p0031) around the last few days in May. Remember my post about a leak I had and didn't know where it was coming from? Asked them to replace the air/fuel/upstream o2 sensor, put a new bolt in the heat shield over the Downpipe cause it rattles at 3k rpm.. and find out where that leak was coming from. The closest subaru specialist is a good hour away. Ryan @turbotime and last I checked when I wanted to get my new IAG block he was pretty backed up so I've asked around where to take my car for balancing,alignment etc(already have taken my STi there 2x) little things like that. So everyone in my local area that also drives subies, hell even saw some Nissans getting work done so but I'm not ready to throw this dealership under the bus or am I? Now get your popcorn 馃嵖 ready.. :hone rings:: so Mr. West unfortunately the leak is coming from the power steering rack and needs replaced+alignment, the upstream o2 sensor replaced with OEM was like around 450/500 and lastly they said the heatshield was cracked and needed replaced(if your under the car it's the back right bolt. it's a grimmspeed heatshield that came with the DP so they said order it and we'll put it in. I just work too much to have time for this BUT imma make time after these numbers 馃ぃ and also Mr. West your rotors and brakes need replacing badly so I just simply ask the price.. like 3000 omfg so I say just replace the power steering rack and order the o2 sensor but don't install it. Ok now the issues I have and finally cooled down.
1. The SRS airbag light is on now when before it wasn't(I've read or should I say skimmed over articles about this after installing the ps rack.)
2. The horn doesn't work and looks as if the center piece of the steering wheel was not attached properly, (what all is removed and put back in with this install?)
3. POWER STEERING FLUID jeeeezzzus dudes WTF IS BELOW COLD MINIMUM by like a whole inch 馃槼
4. PSP sensor was unplugged and i wouldve never noticed it if i didnt remove my alternator cover to clean the carbon fiber. Like what could that have caused over time? 5. And lastly and probably the one that had me the most heated. Lady told me before I left the part will only take a day coming from ATL, and do you want us to wash your car? Absolutely not! I'm sure just about everyone wouldve said the same. I only wash my subie...well they washed the outside about as bad as a blind man, armorall tires(eww) smudges of it everywhere even the damn weather stripping.. so what do you do if you were in my shoes?? What do you demand?
PS that one day job took 9 days...
 

Registered
Joined
1,272 Posts
Nothing. Probably your fault for going to and trusting a stealership. If it were me. I鈥檇 authorize zero repairs and go to the Subaru shop, yes. It鈥檚 an hour away. But it鈥檒l likely still be cheaper by a long shot vs what you鈥檙e paying now. 400-450 for an 02 sensor is absurd, 3k for brakes is because they are brembo, get a different brand and you鈥檒l find the same quality at less than half the cost.

so far as everything else. Take it elsewhere.
 
1 - 4 of 4 Posts
Top