IW STi Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
I think everyone's does this

OK here’s my post from Wednesday drag @ sac raceway. I could post specific times but I’m too lazy to go get them from car. I can post them if anyone really needs them. Any way, the best time was 13.52. I’m very new but it was a significant improvement over 13.7 last week.

I don’t know exact launch rpm but it felt & sounded like 5000. I dragged the clutch a little than dumped once I was moving. The car shuttered and chirped(repeatedly) but did not bog. It was actually cool. Felt like a stuttering hop. Probably not ideal because it lacked smoothness but it felt fast.

I set the shift light at 6900. This is were I might be losing tenths. As a beginner it just might be technique? I still am not sure were the limiter hits as I was listening and not watching the tach. I never hit the limiter. I suspect it is 7300ish????

Whos got the skinny on optimal shift RPM’s. I still ran fast than 2 other STI’s and a pinch faster than the EVO’s. Car has 1700 on it. Is it broke in enough? I sprayed cooler once during staging about 1 min before launch. No ice. Trunk had 100lb woofer but that should not coast more than 1/10 at best.

I think its experience holding me back. My I1 (I think 1/8) was around 8.1. Comparing slips from 4 runs it looks like I am losing time @ end. One run 13.57, last time was 3/10’s faster, than I missed fourth. Other times were similar. Maybe I should be running deeper into red before shifting.

OK, advise please.
 

·
Registered
Joined
·
542 Posts
:lol: How's it going? I am still trying to get those same questions answered as well.

Also, do you remember my last run? I had the Mustang Mach 1 beat through the entire run, and I am sure I would have hit early 13.3 -13.5, but I bounced my last shift @ redline in fourth gear. The Mustang then flew by me @ the end cuz my car stuttered.

It would have been my best run but since I jacked up, I ended up with a 14.1 in comparisons to the Mustang Mach 1, which posted a 13.5, in the quarter mile. Anyways, your advise seemed to help out alot. I shifted around 6500 -6900 rpms, but I noticed a significant power gain through out the powerband. Either way, it was nice meeting you. :)

I hope we can get some questions answered in regards to shifting points in the RPM range. That would be nice. Thanks.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #3
Right on!

Ya , I will get the skinny and let you know. Hopefully I can run again next wed. My very last "fun run" was 13.56? I don't know. Felt great. Should have been 13.2? Well who knows, next time!

Keep in touch
steve
 

·
Premium Member
Joined
·
7,482 Posts
sacsti said:
I don’t know exact launch rpm but it felt & sounded like 5000. I dragged the clutch a little than dumped once I was moving. The car shuttered and chirped(repeatedly) but did not bog. It was actually cool. Felt like a stuttering hop. Probably not ideal because it lacked smoothness but it felt fast.
That might have been wheel-hop which can be very hard on the engine mounts (and the car in general.) If it was wheel-hop, that is something you definitely don't want to do on a regular basis.
 

·
Registered
Joined
·
347 Posts
Re: pppfffttz! $378 for a set of mudflaps????

the sti seems to make peak power at 6000 (at least that's what i've seen in some dyno charts...) so running it 'til 7000 or into the rev-limiter will just slow you down. having that over-rev is great for autocross courses and such, but i'd shift right at the power peak at the drags. try it and compare times...let me know.
 

·
Premium Member
Joined
·
7,482 Posts
Amsoil Synthetics, what's available for your STi

Shifting at your power peak will cause your RPMs to drop out of your peak but shifting at redline, for a properly geared car, should drop you right at the peak in the next gear.

I'm not sure of the gearing on the STi but on my RSX that is the best way.
 
1 - 6 of 6 Posts
Top