IW STi Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
47 Posts
Discussion Starter #1
Proper Idle RPMs?

Just in case anyone else gets this symptom - I recently had the right rear wheel bearing and hub (all one "unit" apparently) replaced on my new STi.

It made a noise right from the get-go under light continuous braking coming to a stop. I figured some minor break thingy like a caliper, so I took delivery anyhow with assurance that it would be fixed with a replacement part. It would make a noise that sounded like a combo of brake grating and a kind of "binding scrunch" as the wheel rotated with the brakes on.

No noise under normal conditions, or hard braking. So if you hear this noise, I'd recommend getting it checked. Seems to be gone now. Factory defect, or did it take a beating? One would hope not. :(

Chris
 

·
Registered
Joined
·
47 Posts
Discussion Starter #3
New parts for STi?

They claimed factory defect, and are supposedly reporting to SOA

Chris
 

·
Registered
Joined
·
410 Posts
Holy smokes!!!! My STI does the same thing. I just thought it was squeaky brakes. But it happens exactly like your description. I am now gonna take the time one of these days to rush it over to the dealership lickity split. I will of course report back what they say. Peace!!
 

·
Registered
Joined
·
437 Posts
road trip

This kind of falls under the brake squeal topic under Handling/Braking but I figured I would post here. Anyone hear anymore about a fix for this? My rear brake/brakes? make an ungodly sound when I am breaking and moving backwards. It is only when I am rolling back out of my driveway or an inclined parking space though. Is this the warped/dented hub problem? Or is it just being attributed to the brembos... as it is in this topic... http://www.imprezawrxsti.com/postnuke/modules.php?op=modload&name=PNphpBB2&file=viewtopic&t=1779
 
1 - 6 of 6 Posts
Top