IW STi Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
273 Posts
Discussion Starter #1
Check out this link to a video below. Its a 8 minute movie showing the Sti kicking ass of a couple of domestic cars.

By the way, check out the guys in the video. I hope not all Sti owners look like that (well maybe in Hicksville, USA :D )

http://forums.clubrsx.com/showthread.php?s=&threadid=83252
 

·
Registered
Joined
·
410 Posts
That video makes me happy and sad at the same time. It was cool to see the STI in action. It was sad to see who owned it. That guy probably has no idea what to do with that car other than drive it in a straight line. Also did he have a cold air intake and aftermarket exhaust system on it already? Where did he get those i wonder? Now lets see some USDM STI's on tracks not dragstrips!!
 
S

·
Guest
Joined
·
0 Posts
I would be very careful with the Z06's and the Cobras. I think the drivers either had bad technique at the tree, or they were asleep and missed the green because these cars are NOT as slow as depicted in this video.

It is cool to see the STi shock soooo many people though. Duh, wake up Detroit this is just the beginning.
 

·
Registered
Joined
·
631 Posts
Did you guys notice that that goof was putting the tach @ like 6000 when he dropped it? That Vette would have taken him in the 1/4 I think.
 

·
Registered
Joined
·
105 Posts
Just as an FYI,
With a stock WRX, I've taken both a new Cobra and Z06 in the 1/8th, and have my car nearly get sucked into a vacuum in the right lane (I was in the left lane) as they blew by me to take the 1/4. These were both good drivers, with both posting consecutive low 12's and even one high 11 (11.99...the Cobra). The WRX runs consistent low 14's with me driving.


Yes, this surprise me also...but with goot RTs and decent shifting, they are just plain incredible out of the hole. Literally, not a car I matched up against that day beat me in the first couple hundred feet. This was the one and only time I dragged the WRX as it is waaaay to hard on the clutch and tranny.

They both came over to ask about mods, and when I said stock, they both looked suspicious. Opened the hood even, but I still think they were suspicious.

I believe the STi will not be beaten by anything else without with some great traction control, (or AWD) serious HP, and good gearing......in a short straight line race. And of course...decent driving/shifting.

Of course, that is not what the STi is for, but it is good to know your cars performance capabilities in all race arenas.

Cheers,
Scott
 

·
Registered
Joined
·
11 Posts
harness attachment points...

ScoobyDo said:
I would be very careful with the Z06's and the Cobras. I think the drivers either had bad technique at the tree, or they were asleep and missed the green because these cars are NOT as slow as depicted in this video.

It is cool to see the STi shock soooo many people though. Duh, wake up Detroit this is just the beginning.
I copied a line from the Lightning website, and since this guy was seen and taped during his run, we can believe it:
"I did a 1.591 60ft, 11.721 @ 114.56 on a stock converter with an air temp of 85+ degrees"

Now you have to realise, the vehicle weighs 4900 lbs without the driver.
My lightning is stock, and I can get 10 runs in an afternoon, with all the 60 ft times between 1.9x and 2.0x seconds. The automatic (truck) transmission takes the abuse in stride.
 

·
Registered
Joined
·
6 Posts
ScoobyDo said:
I would be very careful with the Z06's and the Cobras. I think the drivers either had bad technique at the tree, or they were asleep and missed the green because these cars are NOT as slow as depicted in this video.

It is cool to see the STi shock soooo many people though. Duh, wake up Detroit this is just the beginning.
I agree. I think the STIs are fast and good looking, but dont over-estimate them. They are great performers and hey you cant go wrong with all wheel drive. But, I do think there was something wrong with the Z06 driver. I drive a z06 so I know how it moves, and it moves a lot faster than that one did. He must of had traction control on.

Im really interested in running with an STI, hopefully I'll see one at the track.

Any of you guys live in so cal / woodland hills - burbank area ? I've been looking for some good car guys to chill with since I got my z06 but cant say I have much luck. A lot of the vette drivers are....well...old. ( me =18 ). Anyhow, cant wait to line with an sti. take care.

-Brian
 

·
Registered
Joined
·
467 Posts
Yo...I'm from Evanston too!!!

I got an "error loading codec" message...can't veiw the vid. Any tips?

TK
 

·
Registered
Joined
·
2,468 Posts
Problem with my stock boost gauge

dunno what to say. what player are you using?? what version? it is "stuttery" when played on my laptop. it plays fine on my desktop using wmp9.
 

·
Registered
Joined
·
467 Posts
Are you sure you've got it linked right? I'm getting an audio file...a metal tune. I do hear periodic "racing sounds", however.
 

·
Registered
Joined
·
2,468 Posts
weird. i just downloaded using the link and get both video and that annoying loud music. i didn't make the file so i have no information about what codec was used, etc etc. if you're having problems viewing, you might try upgrading wmp if you haven't already.
 

·
Registered
Joined
·
467 Posts
The first couple times I tried, it attempted to download a codec, which it couldn't find. I tried it again yesterday and it successfully downloaded the codec. I was able to view. The STi's are fast...and I got one...cool.

Now time for some mods.

TK
 
1 - 19 of 19 Posts
Top