IW STi Forum banner

301 - 320 of 577 Posts

·
Registered
Joined
·
907 Posts
Discussion Starter #301
That's good to hear then. If you were doing pulls and the coolant started rising in the reservoir, then I would be more concerned. Sounds like it wasn't bled right the first time. I use one of the Lisle Spill Free funnels on the turbo reservoir. Makes the job much easier.
Yea, I talked with my tuner and he said it never got hot with him. Either way, easy fix.

I'll be putting on my oil cooler at the next oil change as well. Car should run nice and cool during the summer. I also plan to put on my turbo blanket. I'd like to take the car to the track once or twice this year so hopefully I can keep this thing cool when I do it.
 

·
Premium Member
Joined
·
194 Posts
Drove the car around for about 90 minutes or so last night. No over heating at all. Highest the car gets too is about 190. It normally comes back down and sits at 175-185 range.

Also, I figured with this car I would mellow out my mod bug pretty hard. Not even close. -_- Looking at suspension and brake stuff, an exhaust valve cut out, wheels, engine dress up. WHY.
Hahaha. It never ends....
 

·
Registered
Joined
·
1,152 Posts
Yeah, I bought the STi as my daily driver so I wouldn't modify it. My prior daily driver was faster than the STi so the mod bug didn't hold out very long fast forward 2 years and ENJOY YOUR BRAND NEW FORGED SHORTBLOCKKKKK.:lol::lol::lol::rofl:
 

·
Registered
Joined
·
907 Posts
Discussion Starter #304
Hahaha. It never ends....
It'll only end when I don't have a car. I'd probably try to modify a Prius.
Yeah, I bought the STi as my daily driver so I wouldn't modify it. My prior daily driver was faster than the STi so the mod bug didn't hold out very long fast forward 2 years and ENJOY YOUR BRAND NEW FORGED SHORTBLOCKKKKK.:lol::lol::lol::rofl:
Haha, I bought my car brand new and told myself no mods until after the warranty. Fast forward 5000 miles and I was stage 2. fml. Buut, I did drive the car at stage 2 for over 50k miles so I should be proud of that. Too bad the mods were going else where.
 

·
Registered
Joined
·
907 Posts
Discussion Starter #306
Putting the car on a Dyno Jet tomorrow. A friend is getting some pulls in on his H/C/I C6 ZO6 and asked if I wanted to go and run my car too. Of course I'm down for that. Curious what the number difference will be between the two dyno's.
 

·
Registered
Joined
·
907 Posts
Discussion Starter #307
Didn't get a chance to run on the Dyno Jet. They were doing AWD maintenance on the front portion and could only run RWD cars at the time. Oh well.

Side note, raced my buddies 2008 R6 w/205lb rider. We did 40 rolls, by 100mph he had a bike length on me. The car is surprising the hell out of me and it's obvious the dyno numbers can't be the only thing one goes off of. Also, I was running E72(dyno'd on E50) at the time and max PSI was in the 27-28 range.
 

·
Registered
Joined
·
907 Posts
Discussion Starter #310 (Edited)
I still need to get mine installed. Almost a little embarrassed that it's taken this long.
Yea, while I was under the car it looks like I might have a head-gasket leaking as well. This car is really pushing the buttons of what I can take. haha honestly, I'll give it another year and if the problems continue it's getting sold. :lol:

Also, I put in Amsoil 10w-30 and idle PSI is like 12psi. Start up is around 90-95psi. Is it just cause of the 30 as to why the idle is so low? My engine builder recommended the oil too me. Under load and driving the car is in the upper 80psi, and WOT is 100+psi
 

·
Registered
Joined
·
183 Posts
Yea, while I was under the car it looks like I might have a head-gasket leaking as well. This car is really pushing the buttons of what I can take. haha honestly, I'll give it another year and if the problems continue it's getting sold. :lol:

Also, I put in Amsoil 10w-30 and idle PSI is like 12psi. Start up is around 90-95psi. Is it just cause of the 30 as to why the idle is so low? My engine builder recommended the oil too me. Under load and driving the car is in the upper 80psi, and WOT is 100+psi
Interesting your oil pressure moves around so much. Cold start my car is 90-95 and warm idle its around 15psi. WOT stays at a steady 75 even through left and right corners. (Watch my latest Autocross video) I wonder if there are differences between my oil system and yours? I was talking with Dillon and he seems to think his oil pressure actually goes down at WOT because the oil is going past the sensor so fast. He also says around right (or left?) corners he looses oil pressure.
 

·
Registered
Joined
·
907 Posts
Discussion Starter #313
What is your idle RPM?

You have the 11mm right?
Uh, not sure on the idle RPM. I'll have to check it out. haha and yes on the 11mm pump

Interesting your oil pressure moves around so much. Cold start my car is 90-95 and warm idle its around 15psi. WOT stays at a steady 75 even through left and right corners. (Watch my latest Autocross video) I wonder if there are differences between my oil system and yours? I was talking with Dillon and he seems to think his oil pressure actually goes down at WOT because the oil is going past the sensor so fast. He also says around right (or left?) corners he looses oil pressure.
Yea, Idk man.
 

·
Registered
Joined
·
1,152 Posts
My idle is around 900+ so if your's is below that, I would try bumping it up and see what happens to your OP.

Jr. always told me he ran it up because of the higher pressure.
 

·
Registered
Joined
·
907 Posts
Discussion Starter #315
My idle is around 900+ so if your's is below that, I would try bumping it up and see what happens to your OP.

Jr. always told me he ran it up because of the higher pressure.
I want to say Ryan bumped mine up because of the oil pressure.
 

·
Registered
Joined
·
907 Posts
Discussion Starter #319
So, car at 180degF is either at 20psi, or after driving for a while at 180degF it's at like 12psi. RPM's are at 850.
I bumped up my RPM's to 1000 and it was like a 1psi difference in oil pressure. I don't think anything in the engine is bad seeing as warm up pressure is 95psi, today I started driving the car when it was 100degF cause I was late for work, and oil pressure at light cruising was 100+ psi.

Yes, but what is the Oil Temp?

I bet you the oil is probably 40F+ hotter between the 2 measurements.
I'd agree with that, I think next time I go with a 10w-40 oil during the summer to help with hot oil pressures.

From what I remember reading the (X or XXw) is for start up measurements, and the (YY) is for operating temp measurements. Correct? Probably could just google this.
 

·
Registered
Joined
·
123 Posts
I bumped up my RPM's to 1000 and it was like a 1psi difference in oil pressure. I don't think anything in the engine is bad seeing as warm up pressure is 95psi, today I started driving the car when it was 100degF cause I was late for work, and oil pressure at light cruising was 100+ psi.


I'd agree with that, I think next time I go with a 10w-40 oil during the summer to help with hot oil pressures.

From what I remember reading the (X or XXw) is for start up measurements, and the (YY) is for operating temp measurements. Correct? Probably could just google this.
Basically that. So you may get a little bit of a difference going to the 10-40 only because it will be thicker than a 5-40 even at temp, but it will still be in the 40 weight range when hot.

Weird how you're at over 100 when cruising though, have you tested with a mechanical oil pressure sensor?

You may be better off going to castrol 5-50w synthetic. Has a good amount of ZDDP in it because it was originally formulated for older v8's with flat tappet cams.
 
301 - 320 of 577 Posts
Top