IW STi Forum banner

61 - 80 of 353 Posts

·
Registered
Joined
·
79 Posts
very little oil drained from mine
you dont have to do much just bend it out of the way to replace it and clean it up later.
iirc when i took the bolt out of the back of the block oil tried to drain quickly, be prepaired to swap it quickly there.
 

·
Registered
Joined
·
881 Posts
How the heck do you ge to the 2nd bolt? The one on the back of the block? I can't even see it. There's a silver shielded line running right there.
 

·
Registered
Joined
·
881 Posts
reuse the stock ones
Right, but a few people mentioned that they had to use 2 to get the one connected to to the block to fit properly. I figured it'd be good to have some extra.

And again, how the heck do you get to the bolt on the block (number 2)? It seems to be covered by another line.
 

·
Registered
Joined
·
881 Posts
And i t looks like I'm leaking from the connection. Maybe a crack within. Anyone seen it fail there? I'm talking about the connection circled in green below.

 

·
Registered
Joined
·
79 Posts
Right, but a few people mentioned that they had to use 2 to get the one connected to to the block to fit properly. I figured it'd be good to have some extra.

And again, how the heck do you get to the bolt on the block (number 2)? It seems to be covered by another line.
a local hydraulic supply should have more copper gaskets. i had to use 2 on the back of the block but when you take it all apart you will have extra ones on hand.idk what other lines are there. it is cramped but i was able to get to it without removing anything, except for the heatshields maybe which were previously removed.
 

·
Registered
Joined
·
1,076 Posts
Very nice. One more thing I can replace that the factory crap likes to break. Good info. ;)
 

·
Registered
Joined
·
552 Posts
very good info here... im def thinking about replacing it with that oil line set-up... just kinda nervous to do the install myself
 

·
Premium Member
Joined
·
1,120 Posts
Hey, great mod, but I never got around of installing it, went rotated and used the lines that came with it. Though I have the complete kit that UltimateLurker posted, if anyone's interested, I'll let it go for $50 shipped. PM me if interested. Thanks.

Sorry if I stoled the thread for a tiny bit... but didn't want the Lurkers kit to go unused and handed it over to more capable STI owner at great price. It's SOLD.
 

·
Registered
Joined
·
79 Posts
Hey, great mod, but I never got around of installing it, went rotated and used the lines that came with it. Though I have the complete kit that UltimateLurker posted, if anyone's interested, I'll let it go for $50 shipped. PM me if interested. Thanks.
great deal condisering it cost around 95 with shipping for everything on the list.
 

·
Registered
Joined
·
881 Posts
So, out of the two shorter lines, which goes to which spot? The longer one to the turbo and the shorter to the block, or vice versa?
 

·
Registered
Joined
·
881 Posts
Well, I got everything together. Let me say, this is WAY more difficult that most people made it out to be, or maybe it's just my bad luck. Anyway, after installing everything, I'm still leaking from the block connection. I used 2 washers on the back side, as suggested by a lot of peopl, but it's still leaking. I just order some 1/2" crush washers, so hopefully the new washers will solve the problem.
 

·
Registered
Joined
·
552 Posts
keep us posted ill be installing mine this week and im hoping it doesnt leak... so its leaking from the back side of the motor? anyone here have any suggestions for a fix for this???
 
61 - 80 of 353 Posts
Top