IW STi Forum banner

41 - 60 of 130 Posts

·
Registered
Joined
·
1,266 Posts
Discussion Starter #41 (Edited)
Re: Tony's UGM STI - Plan B [update]

Holy crap,

A second RallyCross is planned. I must attend! haha. Probably not the best idea for my car right now. :(

 

·
Registered
Joined
·
1,266 Posts
Discussion Starter #44
Re: Tony's UGM STI - 2nd RallyCross :(

SOCOM RallyX - March - Subaru Meet - YouTube

Only chance I got to let it rip out on the field. It got too muddy and my tranmission love tapped the ground on some bad ditches. That was enough for me. Can't afford to rebuild my tranmission at the moment.

That WRX got stuck because of speed and the depth of the mud, It was about 6-7" deep, He was also going fairly slow.

Only reason I was so close was because it was only during hot laps. We "can't" race each other due to the agreement. Unless we were timing the event. It was mainly for us subbie owners to let it rip and have fun.

In other news.
600 miles later and no oil consumption :tup:
 

·
Registered
Joined
·
1,266 Posts
Discussion Starter #46
Re: Tony's UGM STI - 2nd RallyCross :(

Just rolled 2500 miles since the oil consumption test started.. Every time I went in, I got a back a its fine. Nothing out of the norm. :D

Has anyone here used the Covert Oil Pickup? Or have used Killer B one.

Thinking of buying one soon. And get it installed among with my shifter bushings.
 

·
Registered
Joined
·
1,266 Posts
Discussion Starter #47
Re: Tony's UGM STI - Detention low load? :(

Okay so on first start up after I changed out the spark plugs. It was fine for about 10 minutes. 5 minutes of idling and another 5 of driving. Nearly the end of the drive. I was mainly around 3000 rpm. I was in my neighbourhood. I started to hear some knocking, But at the time I didn't realized it. I pulled over and shut off my car to make sure nothing was hitting anything. Surely there wasn't anything. I turn my car back on and nothing. No more knocking.

This is worrisome.

So recap.

- The ECU was cleared due to the lack of battery for about 5 hours
- I'm on 94 octane
- New sparks

Could tighting my sparks too tight cause this as well?
 

·
Registered
Joined
·
1,266 Posts
Discussion Starter #48 (Edited)
Re: Tony's UGM STI - Detention low load? :(



Doesn't look half bad. <3

Removed the spoiler for this..







time to get it temporary painted so it doesn't rust even more.

But. Seriously thinking about getting another trunk now. It looks so clean. Without the spoiler.

In other news,

I was told by subaru that my turbo is going and is the reason why i've been consumption oil. :tdown:

However, I think I found a replacement. :tup:
 

·
Registered
Joined
·
339 Posts
Re: Tony's UGM STI First little rally

Went off road today Did some rally like time events with the locals.


Throwing the under cover back on.







That's all I have out of my phone. I'll post more as the others photographers post theres.
That last shot is awesome!
 

·
Registered
Joined
·
1,266 Posts
Discussion Starter #53 (Edited)
Re: Tony's UGM STI - Gravel pics - RIPCSK

Dumping some more pics.

Left me a nice long trail of dust into the garage Haha!


Rear bumper/Apron caked


Rear end shot


Gravel!


----------------------------------------------------------------------------------


Apex performance now carries and stock Killer B oil pick up tube! Check them out, https://www.facebook.com/apexnd. [email protected]
 

·
Registered
Joined
·
1,266 Posts
Discussion Starter #54
Re: Tony's UGM STI - Only 10PSI of Boost? - RIPCSK

Boosting issue -

I recently went WOT and i've noticed my boost isn't hitting target. Both in 10c weather and 20c. I'm hitting max of 9-10PSI

From what i've read and learn it's a pill resistor issue? Which seems about right since I did have to remove it so I can install my turbo on.

From what I've gathered from my logs, My DAM is only at .81 and got a fine knock of -1.4 for half a second. My Dynamic Ad ranges from 0.2 to 3.61 From what I understand a Postive dynamic advance is fine. Adding timing. A negative is pulling timing?

https://docs.google.com/spreadsheet/ccc?key=0AscX9TTleFzRdC1SbWI1bXNOZ2VXbklqT3ZhOWNwNkE

I also want to add that I haven't resetted my ECU after the turbo install. Should I have?
 

·
Registered
Joined
·
1,266 Posts
Discussion Starter #55 (Edited)
Re: Tony's UGM STI - Kartboy Shifter Bushing - RIPCSK

Finally installed my kartboy shifter bushing.

- Installation notes:
For me pulling the shifter out(along removing the cross members) and mounting the rear bushing was the best option to do it. It took forever trying to get the old ones out. After that the rest of the installation was a piece of cake

- First impression
Oh how I love the tranny whine, I might go with tranny mounts bushing upgrades soon. Shifting is so much more crisp. It pops into place, rather than "falls". I feel so much more confident that it in gear rather than almost there. I gotta put a little more effort into my gear changes. But that's about the only draw back I can think of. That's not even a very "good" one.

I highly recommend them it anyone with a WRX/STI. It completely changes the feel of it.
 

·
Registered
Joined
·
1,374 Posts
Re: Tony's UGM STI - RIPCSK

Nice pics! Really wish we had some snow around here. Oh, and my car to actually even be able to play in the snow.

How's the replacement turbo holding up? Oil issues are resolved I presume.
 

·
Registered
Joined
·
1,266 Posts
Discussion Starter #59
Nice pics! Really wish we had some snow around here. Oh, and my car to actually even be able to play in the snow.

How's the replacement turbo holding up? Oil issues are resolved I presume.
Turbos doing good.. I am still burning a bit of oil.

At this point. I'm driving till the motor blows lol. Then built motor

But I have a feelings its the pvc valve that's clogged. I pulled one of my lines off the ic and it was gummed.
 

·
Registered
Joined
·
1,374 Posts
Re: Tony's UGM STI - RIPCSK

Turbos doing good.. I am still burning a bit of oil.

At this point. I'm driving till the motor blows lol. Then built motor
Heh, I know how that is! I was having similar issues. Was checking everything I could. Even had decent compression but I was burning a ton of oil by the end. The motor finally gave out in October. I believe it spun a bearing in addition to melting part of #4. New motor should be done by the end of the month. We also opted to go with a new turbo as a precaution since I was pretty high mileage anyways.

I hope you have better luck than I do. I managed to do a little damage to the heads by driving it till it died...
 
41 - 60 of 130 Posts
Top