IW STi Forum banner

1961 - 1964 of 1964 Posts

·
Registered
Joined
·
966 Posts
That sucks about your bearing.

I had my EWG plumbed like yours, with only 1 fitting being used on the EWG, and the car needed a considerable amount of WGDC to regulate boost.

once I added the 2nd port, the WGDC went down so far that I needed to swap in a smaller spring. I was hitting 30 psi at 4% WGDC where it took 95% to hit 30 psi before.
 

·
Registered
Joined
·
4,885 Posts
Discussion Starter #1,962
58554

58555

58556


So it looks like it had oil starvation. Guess I used too much sealant on the case halves which fell off and clogged the pickup. The oil pan sealant was intact and looked fine. All the rod bearings looked like they were getting hot. I'll most likely send the pistons and rods back to Manley for inspection.

Already ordered all the seals, gaskets, new 3 port, 1/4" fittings and new 625+ head studs. I'll be getting new valve seals too since it always had bursts of smoke at start up but would go away.

Not sure which route I want to take on the block though:
A) Have the case bored to a .03 PWC vs the .025 its currently at, send the pistons and rods back to manley for inspection and attempt to build it again.
B) Get a new prebuilt OEM sb :/

IAG said the crank, rods and pistons are most likely no good from the oil starvation and worst case is the case is no good too. I guess we will see after inspection.

Good luck with the rebuild; getting the heads decked?

Get in touch with Phatbotti Tuning or JRtuned, they'll do you right.
The heads only have 1100 miles so shouldnt need tk be redecked again. I'll double check, just haven't yet.

Are you still in KS?
 

·
Registered
Joined
·
4,885 Posts
Discussion Starter #1,963
That sucks about your bearing.

I had my EWG plumbed like yours, with only 1 fitting being used on the EWG, and the car needed a considerable amount of WGDC to regulate boost.

once I added the 2nd port, the WGDC went down so far that I needed to swap in a smaller spring. I was hitting 30 psi at 4% WGDC where it took 95% to hit 30 psi before.
Wow! Didn't realize it made that much of a difference. What size springs are you using to achieve your 30psi now?
 
1961 - 1964 of 1964 Posts
Top