IW STi Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
I have a 2008 STI and just put a new Cobb stage 1 drivetrain package in it. Before I put the shifter in I was having a ton of play while in gear, it almost felt like neutral. I figured the bushings would fix my issue. After installing them it feels as though I still have the same amount of play. The car has 160K on it with a stage 2 clutch and the Cobb stage 3+ package on it. Its the original tranny. Any ideas on how to fix the slop?
 

·
Registered
Joined
·
657 Posts
I had the same "issue" in my 06. I got the TIC (Turn in Concepts) holy shift kit, as well as their tallboy kartboy shifter. completely got rid of the issue. it had shift linkage bushings (probably your issue here, these like to dry rot and fall out, my oem ones had completely vanished lol), front/rear shift bushings, and crossmember bushings....oh and i also got a new trans mount at the same time.
 

·
Premium Member
See about
Joined
·
6,136 Posts
All the bushings in the shifter might be replaced with any of several brands. The Cobbs are good.

To my knowledge, the linkage is available with the stock bushings which are quiet, and the TIC which is all metal . . .
 

·
Registered
Joined
·
568 Posts
do any of these address any bushings other than the front an rear? i have a ridiculous amount of play also where everyone else who drives the car (tire shops as i do everything else...) stall it due to leaving in gear...
 

·
Premium Member
See about
Joined
·
6,136 Posts

·
Registered
Joined
·
657 Posts
do any of these address any bushings other than the front an rear? i have a ridiculous amount of play also where everyone else who drives the car (tire shops as i do everything else...) stall it due to leaving in gear...
the linkage bushings is likely what you need.
 

·
Registered
Joined
·
568 Posts
copy that, thank you! i otherwise have the prothane bushings for the front an rear...will update my results when i do this!
 
1 - 7 of 7 Posts
Top