IW STi Forum banner

1 - 20 of 35 Posts

·
Registered
Joined
·
542 Posts
Discussion Starter #1
I am not sure where to post this but here it goes never the less....

I just installed a Short Ram Intake (injen) to my STi & it sounds great but I've noticed that while in 6th Gear, between 70 to 85 mph, it accelerates real slow.

With the Stock INtake, I had better pick-up & accelaration during that range. Has anyone else had this negative effects with an aftermarket INTAKE to their STi?

Is it worth keeping?

As of now, I think not. What do you all think?
 

·
Registered
Joined
·
2,823 Posts
well, I have the airinx with an invidia DP and a Hallman boost controller and it kicks like no tomorrow, so I say a short ram is worth it. Check with Godspeed, they have dynoed using the SUS or blitz, MBC and DP to just over 300hoserpower at the wheels :eek: it must do something.....

the final decision is always up to you.
 

·
Registered
Joined
·
2,773 Posts
Airinx? Never heard of it.

A short ram shouldn't mess with you like that. The only reason you would loose torque at low RPM is if the intake was somehow creating a low air velocity situation, but that shouldn't be affected with as long as the intake track is on our cars.

You sure it wasn't just a hot humid day?
 

·
Premium Member
Joined
·
922 Posts
The only problem I have heard of is that a different intake (short ram CAI) can lean out the engine if not used in conjunction with an engine management system (Unichip, Utec, AccessECU, ...)
 

·
Registered
Joined
·
2,823 Posts
CloNeGTS said:
Airinx? Never heard of it.
Airinx makes them and Greddy sells them. I don't call it a Greddy because they didn't make it.
 

·
Registered
Joined
·
32 Posts
HKS Carbon-Ti Exhaust Install / Problem

I had a Perrin short ram intake and sold it on EBay. I had issues with it. The main thing was it was laggy off the line compared to stock. I also had turbo/bov issues with stuttering at higher speeds at WOT. Also, It made the bov and turbo very loud.

No good for me but, as always, YMMV.
 

·
Registered
Joined
·
542 Posts
Discussion Starter #7
Well, after encountering the delay in high accelaration, stumbling performance & noticing that my RPMs rising quicker/higher than usual, I put back the OEM filter, and my car feels & performs back to normal.

I am a very savy & experienced guy with cars but I did experience a quirk never the less on my STi w/ the Injen Short Ram (CAI modified). Overall, I like the sound but I am not happy with the problems that I did encounter. AnYwAyS, problem is now solved. Thanks again for the feedback.
 

·
Registered
Joined
·
2,773 Posts
Hmm....disappointing results so far. I'd say it was not having an exhaust that made the difference....but then Hummer/Quigybo wouldn't have had the same issues.

Damn. Well, looks like it's time to stick with the resonator box removal for a little extra sound under the hood.
 

·
Registered
Joined
·
392 Posts
CAI installed will get you more noise when spooling.

TC will also start spooling 500+/- earlier. Stock BOV would also be very clear.

Finally, no CEL at all (at least with the Blitz)
 

·
Registered
Joined
·
392 Posts
Well, I am going to try installing the short ram once again to test & determine the problem or to a least solve it.

I also plan to put some silcone gel around the hole where the O2 sensor thing goes into. Maybe I had a air leak of somekind. I will keep you posted....
 

·
Registered
Joined
·
542 Posts
Discussion Starter #12
ooopppss... forgot to log in. That was me who posted above...
 

·
Registered
Joined
·
542 Posts
Discussion Starter #15
Yes. Thanks Rob.
 

·
Registered
Joined
·
542 Posts
Discussion Starter #16
any been to irvine subaru

WELL, I did it again. I re-installed the Ingen Intake, and I notice no problems now @ regular speeds, but I still get the same LAGGING acceleration from 70 to 80 mphs in 6th gear. It TAKES 4 to 5 seconds to reach 80 mph from 70mph w/ the Ingen Intake.

I talked to my buddy who works @ the performance shop & I told him about this problem. He then called INGEN & spoke w/ a rep. Basically, the rep told him that some of the pipes were made w/ defictions. WTF?!

Anyways, that INGEN intake is coming off tomorrow. Also, I noticed WAY BETTER accelaration w/ the stock intake. 2 to 3 seconds to reach 80 mph from 70 mphs. Now, that's what I am talking about!!! :)

But on a positive note in regards w/ the INGEN intake, it has a better sound & it did feel like it gave me better low end "pep", when cruising around town. Basically, I felt a little quicker w/ the INGEN on.

Regardless, I am not sacraficing top end speed. Peace out fellow STi members.
 

·
Premium Member
Joined
·
922 Posts
My Black w/Silver - Tinted w/Turbo back exhaust

Did you get an ECU reflash? My guy at Huffines said that without a reflash or piggyback system the computer will get confused with all the extra air and the engine will not perform as well. This might be what is happening with yours. I think my intake is going to be one of the later mods I will do because I want to get an ECU upgrade and they are not out yet. Anyway, thanks for the info.
 

·
Registered
Joined
·
2,773 Posts
The problem might be.....it appears you have bought a knock-off intake.

THE BIG COMPANY IS INJEN.....J...J...J...never heard of INGEN.

;)
 

·
Registered
Joined
·
542 Posts
Discussion Starter #19
The problem might be.....it appears you have bought a knock-off intake.

THE BIG COMPANY IS INJEN.....J...J...J...never heard of INGEN.
... YES, YES, YES... that's the one!! Thanks again Rob. I just watched Jurassic Park 3 the other day, and I keep quoting that in my head! Thanks again for the clarification. I am such a big goof. Sorry for the miswording. :)
 

·
Registered
Joined
·
26 Posts
I installed the Injen CAI and I'm also having that same problem. So it's coming off and i'll keep the stock box. I think in order for it to work properly,it should be combined with a downpipe and exhaust and ecu.
 
1 - 20 of 35 Posts
Top