IW STi Forum banner

1 - 7 of 7 Posts

·
Drive True
Joined
·
6,833 Posts
Discussion Starter #1
What's the quickest way to launch? Clutch-drop at 4k? I've tried that...well more like at 3500 rpm and I know it's bad but I wonder...am I doing it wrong? I thought you lift your foot off the clutch quickly, but usually I end up bogging the launch.
 

·
retired mod
Joined
·
4,012 Posts
i havent driven the us spec STi, but other awd cars i driven including my 99 STi i had back in australia i would let it out quick at 6500rpm+ yeah it is brutal but it gets the car off the line. thing is i read in a mag that dial anymore than 3500rpm in the usdm STi and let the clutch up and she wheel spins... so i dont know why ur bogging.
 

·
Registered
Joined
·
631 Posts
I've done it in a WRX and had to go near 5000 for the boost to be strong enough to run the car. Try upping it just a little more. Make sure that you don't lift on the throttle, though...
 

·
Registered
Joined
·
59 Posts
murley said:
I've done it in a WRX and had to go near 5000 for the boost to be strong enough to run the car. Try upping it just a little more. Make sure that you don't lift on the throttle, though...
Wow. I hope you are not doing "experiments" on the lot with the STi's that arrive before the unfortunate new owners have a chance to come pick them up. :wink:
 

·
Registered
Joined
·
410 Posts
That brings back memories. I worked at a BMW dealership one summer 5 years ago. I had my pick of any of the used cars on the lot for running daily errands. I BEAT THE HELL OUTTA THOSE CARS!!! M3, M roadster, 540IL six speed.....heheheheh. Thats why i am always on edge when I buy a car cause i know first hand what happens to them on the lot. Peace!!
 
1 - 7 of 7 Posts
Top