IW STi Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
331 Posts
Discussion Starter #1
Hi... im new here, so this is my first post. this site is really cool by the way... anyway, ive had my STi for about two months and i just installed my Trubo XS Ti full turbo back exhaust system with high flow cat. It sounds and looks great, but i almost feel as though im loosing power. Turbo XS gurantees 27 HP at the wheels and through low and high RPMs with a 0.2 psi increase. It might just be my imagination because ive never been a fan of modifying cars because of all the hassle etc. Could anyone help me out, or anyone with this exhaust? Thanks alot...
Kinda a stupid question i know
 

·
Registered
Joined
·
858 Posts
remove negative post on battery. wait a few minutes. reconnect batt.

let ecu relearn. give a few days (depending how much you drive). then report back here...
 

·
Registered
Joined
·
331 Posts
Discussion Starter #3
thanks alot... ill let u know how it turns out....
 

·
Registered
Joined
·
385 Posts
Better yet, next time during the install just disconnect the negative terminal so by the time your ready for the 1st drive things are ready to go. This is a good real of thumb for any car mods.
 

·
Registered
Joined
·
331 Posts
Discussion Starter #7
FS: 04 sti black with silver wheels located in mass

thanks for all your advice... i re programmed the ECU and now it seems like its back to normal. Ive heard of people on the other forum about TBE causing them to run like 18 psi... im running 16 at the most... i hope i didnt just waste money on something thats going to slow my car down and hurt its reliability. Is anyone running a TBE gaining performance or having no problems ? and whats an FCD?
thanks
 

·
Registered
Joined
·
759 Posts
ebraunschweiler said:
thanks for all your advice... i re programmed the ECU and now it seems like its back to normal. Ive heard of people on the other forum about TBE causing them to run like 18 psi... im running 16 at the most... i hope i didnt just waste money on something thats going to slow my car down and hurt its reliability. Is anyone running a TBE gaining performance or having no problems ? and whats an FCD?
thanks
I have the TurboXS with high flow cat. I am using the quieter exhaust{not the RFL-Ti}. I had the RFL-TI but I had some issues with discoloration and a slight melt. TurboXS exchanged mufflers{and paid all shipping}. I like it a lot and it does not slow the car down. :D

I would watch the bumper if you have the RFL-Ti. TurboXS was having a slight redesign so it is probably ok but better safe than melted.
 

·
Registered
Joined
·
331 Posts
Discussion Starter #9
Yea i have the ti muffler, but i made sure i wasnt going to have the melting problem becasue i knew that was happening. TurboXS guerenteed me though that they re designed the ti muffler so it wont happen anymore, havent had any problems yet. I love the way the exhaust sounds... How does Youre regular TXS muffler sound? is it alot quieter? i was thinking about getting that one too because i didnt want my car to sound too riced out. But im really happy with it. I dont understand why everyone seems to be complaining about boost creep and fuel cut... i had a little problem in the beginning, but now its fine. I still cant wait till engine managment comes out so it will perform at its best and not be dumping so much damn fuel.... Anyone got an idea when its comin out by the way?
 

·
Registered
Joined
·
1,402 Posts
apparently not....i have heard turboxs is feverishly workin on it(no really....i heard a conversation between turboxs and the owner of the shop i go to and they say by feb the will be available) cross your fingers cause that is the final piece of this puzzle we call the sti
 
1 - 10 of 10 Posts
Top