IW STi Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
63270

Before Purchase - 117k Miles - was up for sale because it had jumped timing, or so thats what the prognosis was
63271

The teardown! Cyl 4 lost a rod bearing, heads were super duper shot, case in general was very... gunky?
63273

Little whiteboard action; tagging and bagging, and keeping the parts list updated when finding xyz was 'broke/missing'
63274

Cold tanked the halves to be sent off for machining
63275

63276

Bolt cleanup to make re-assembly go smoother
63277

Barb clip on the TB - removing the TB Coolant loop.
63278

OEM vs KillerB, huge upgrade!!!
63279

Fresh Heads (No port work, just stocker replacement w25s with GSC seals, oem ones ran on the spun bearing too long and all the journals were past tolerance)
 

Attachments

·
Registered
Joined
·
8 Posts
Discussion Starter · #2 ·
63280

New rods
63281

63282

Previous owner had 225s stretched on the 8.5 bbs rims, swapped them out for some lightly used 255 super sports
63283

New Meats

63284

63285

Still had the stock suspension, was a little tired, found a good deal on a low mile VA Chassis suspension for now. Just bent the front brackets for the holder and ran a m6 ss nut+bolt combo in the holder.

63286

Case halves returned!
63287

Cam Gears all returned, exhaust side was rebuilt, intake side are new (Old ones were damaged beyond repair)
63288
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #4 ·
63299

Both OEM ground straps were shot (Copper units) ended up doing a modified version of the 'BIG 3'
63300

63301

0WG NEG leads to a 1-4 4AWG Output, mounted to the frame rail with a M6 Bolt
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #6 ·
63305

Wiring up WBO2 and Oil Pressure Gauges (WBO2 is using 5v signal for AP logging)
63306

63307

Pretty close to being pinned up, got compression, spark, fuel, and good air, gotta go through and clean up all the ancillary stuff.

Also waiting on seals for diff / axles / and I overcooked the rear main so its got a minor oil leak out of the bellhousing that ill drop the trans and replace the rear main before it goes on a maiden ring break in voyage.

We had to plug the passenger side head for the oil feed design change, oops.
Fix issues with the oil pressure sensor.
Also the coolant temp sensor (from the gauge pods you can see) is done for. ECU reading -40; cluster reads max heat, fan stays on all the time. New one ordered as well.
 
1 - 6 of 6 Posts
Top