IW STi Forum banner
21 - 23 of 23 Posts

·
Registered
2021 WR Blue Pearl WRX STI Base
Joined
·
5 Posts
I had RCE yellow's on my 08 and nothing like this happen, so I'm ruling those out.
Why? this seems like the most likely culprit imo. Just because one car didn't have issues, does not mean that this one will.

Regardless of the source, to diagnose, you could try lifting the car so the rear wheels are off the ground and then separately jack up the wheel to see if anything creaks and if anything is rubbing or making contact where it shouldn't.

This bushing on the lateral link was the culprit:
63607

After disassembling and applying A LOT of grease/silicone lube both around the bushing and inside the bushing, the problem went away entirely.
This is a good place to check as well since it could make a lot of noise up the shock body.
 

·
Premium Member
See about
Joined
·
6,272 Posts
A note too those doing significant performance suspension modification: if you are going to be picky about noise, just don't do em :)
That's said if you are having a bearing issue, it's not an acceptable noise. I love driving my 05, . . . . . but it isn't nice . . . and non-enthusiasts older than 30 (normal people) don't like it.
 
  • Like
Reactions: VisMajor

·
Registered
Joined
·
252 Posts
There is a small exhaust shield center of the car. The bolts come lose all the time on new ones. It is often the culprit causing the creek that sounds back of the car. It sounds like a wagon on the Oregon trail at slow speeds over bumps.

Give those bolts a check.
 
21 - 23 of 23 Posts
Top