IW STi Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
175 Posts
Discussion Starter · #1 ·
Ever since I replaced my whole exhaust system... I keep getting a darned CEL.

I now carry CEL Eliminators ... they are on special $13.00 shipped (usps) each. (They are made by Helix of Japan)

They are only good for the P0420 Cat. Inneficiency Code ... ready to wire in ... available for the 04 WRX/STi and the 02/03 WRX.

Must specify.

I only have 14 total in stock. Paypal to : [email protected]

 

·
Registered
Joined
·
2,823 Posts
That IS for the 04 STi.

I have one and it solved the CEL imemdiatly. You solder it inline with your rear O2 sensor and it alters the voltage signal to the ECU fooling it into thinking everything is working properly.
 

·
Registered
Joined
·
175 Posts
Discussion Starter · #4 ·
Xman is correct! Thanks for the reply. We have them available for the 02/03 WRX and for the 04 WRX & STi.
 

·
Registered
Joined
·
175 Posts
Discussion Starter · #5 ·
Am I the only person who owns an STi ... that had this problem? I couldn't stand the Cruise light flashing anymore ... it was driving me crazy! :D
 

·
Registered
Joined
·
175 Posts
Discussion Starter · #7 ·
I still have some left .... paypal away! I'll mail the same day! (as long as I get the paypal before 3pm)
 

·
Registered
Joined
·
175 Posts
Discussion Starter · #9 ·
Unfortunately... no ... heck if there was enough demand for it ... I could probably see about getting them made ...
 

·
Registered
Joined
·
1,879 Posts
It's a just a resistor of a certain resistance..... search the forums, someone was offering a CEL fix for that a while ago.
 

·
Registered
Joined
·
392 Posts
bitabur said:
It's a just a resistor of a certain resistance..... search the forums, someone was offering a CEL fix for that a while ago.

hahha, I cant believe someone will actually sell a resistor for $13.......It cant be that hard to do a home made 'kit'. Basically what the resistor does is lowering the current through 'that transmisison line' and not 'turning ON or OFF' a transistor or a logic gate......thus disabling that particular sensor/fooling the sensor to believe the same electric signal is always there < the signal that makes the ecu think emissions are ok >

damn, where does this resistor go ????


Guys, if the problem is fixed by adding resistance then its clear that all you have to do is attenuate the electric signal...........go to ur nearest 'electronic supply shop' and buy a .5 W, watt, or higher, *.* ohm resistor and solder in in series at the SPECIFIC location. I dont know this location.

let *.* = the highest rating you can get to be on the safe side.
 

·
Registered
Joined
·
1,879 Posts
No, i'm pretty sure it has to be a specific resistance.

I wouldn't fuck around with this stuff, it can blow your airbags and cause a lot of dammage.
 

·
Registered
Joined
·
175 Posts
Discussion Starter · #13 ·
Well, then make your own kit, and sell it here somewhere. Next time, start your own thread too.

And by the way, you're not just buying a resistor ... you are also paying for someone's time to make it .... and ship it .... surely $13 won't absolutely break everyone's bank account. I've seen much much worse, for a lot more money.

Thanks,

Brett
 

·
Registered
Joined
·
175 Posts
Discussion Starter · #14 ·
Liquidating ....

$10 each ..... shipped regular mail.

Paypal to [email protected]

While supplies last. If out of stock, I will "refund" the paypal.

Thanks!
 

·
Registered
Joined
·
86 Posts
Need4Speed said:
Liquidating ....

$10 each ..... shipped regular mail.

Paypal to [email protected]

While supplies last. If out of stock, I will "refund" the paypal.

Thanks!
paypal sent. thanks
 
1 - 16 of 16 Posts
Top