IW STi Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
350 Posts
Discussion Starter #1
I was trying to input my VIN and it says it doesn't support it yet or it is wrong. Does anyone use this website? It is very nice to keep track of maintenace, schedules, etc.

-dp
 

·
Registered
Joined
·
350 Posts
Discussion Starter #3
Yeah, I already did. I was just curious if anyone else used this site.

-dp
 

·
Registered
Joined
·
98 Posts
I've tried and although it recognised my VIN as an STi, the link to the owners manual pulls up an Outback or something weird. The maintenance schedule was also totally different from my owners manual. I email their support desk months ago and was told 'we're working on it'. Nice idea though.
 

·
Registered
Joined
·
2,468 Posts
i applied to for an account back in may when i bought the car. they were supposed to send me something by mail. i'm still waiting.
 

·
Premium Member
Joined
·
2,802 Posts
I singed up with no problems... actually I already was from my 98 Legacy that I sold. I removed the Legacy and added the STi and put in all the maintenance I had done on it so far.
 

·
Registered
Joined
·
350 Posts
Discussion Starter #9
I got a reply from SOA saying my car was still listed as "presale" on their database. They will be sending me an email once they receive my info from the dealer.
 

·
Registered
Joined
·
983 Posts
That means the system cannot catch up updating fast enough because the STi's are selling too fast!! :p
 
1 - 11 of 11 Posts
Top