IW STi Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
1,419 Posts
Discussion Starter · #1 · (Edited)
P0301 Cylinder 1 Misfire Detected
My car through that code 2 days ago, i checked it today with my cobb ap. The car seems to run fine... when the code came on the car had a rough idel. Its happend before as well it just went away and came back. I finally had a chance to see what the code was today. So what do i do now? Take it in? i have a TBE and ap map on it... could it be a bad injector? And will warrenty cover this? It went away earlier then i got gas and the rough idel happend and the code came back...
 

·
Registered
Joined
·
3,082 Posts
I was just about to ask the same thing today... Mine was a PO302 & PO304.

Yesterday while just cruising around I threw my first CEL ever on this car and it turned out to be a misfire cylinder #2, #4, and a 3rd code that showed up on the Cobb AP as "?????".

I cleared them last night, but didn't start the car up until this morning and I noticed it was idling where it normally does, but it felt kind of like it wanted to stall or something especially when I first started it up...

Does anyone know if this is something to be worried about :confused:
 

·
Registered
Joined
·
2,490 Posts
Yes, most likely it is an injector. They are covered under warranty. I have one waiting to be replaced in my wife's Legacy GT. My dealer said they replace 5-6 injectors a month. Each one had misfire codes. Once the injectors were replaced, the code went away and didn't return.
 

·
Registered
Joined
·
385 Posts
did you reflash the ECU or are you just running a real-time map over the stock one?

I'm curious to see if the dealership will take care of you on this (since you have mods). Def. revert to stock before you go, IMO.
 

·
Registered
Joined
·
1,419 Posts
Discussion Starter · #5 ·
elusiveDesires said:
did you reflash the ECU or are you just running a real-time map over the stock one?

I'm curious to see if the dealership will take care of you on this (since you have mods). Def. revert to stock before you go, IMO.
I havnt tried the realtime maps. Im running the S2 base map. Im waiting til i get a turbo upgrade and stuff then ill get a protune. As for mods. i dont think my mods should effect an injector? My friend has a STi and his turbo blew. He has bov, and tbe. They where on the car when he took it in and they didnt say anything about the mods and replaced his whole motor and turbo under warenty. I guess they said the turbo was defective and one of the blades broke and shot into motor...
 

·
Registered
Joined
·
4,287 Posts
You should run both a base map and a real time map. It is usually recommended to run both. I don't know if this will fix the problem at hand though. You may just have a bad injector. If you have larger injectors then I would guess that the idle needs to be turned up for the larger injectors, but since you don't then I would guess it is a faulty injector.
 

·
Registered
Joined
·
1,419 Posts
Discussion Starter · #7 ·
ninjaboy76 said:
You should run both a base map and a real time map. It is usually recommended to run both. I don't know if this will fix the problem at hand though. You may just have a bad injector. If you have larger injectors then I would guess that the idle needs to be turned up for the larger injectors, but since you don't then I would guess it is a faulty injector.
How do i run both maps? Do you mean at the same time?
 
1 - 7 of 7 Posts
Top