IW STi Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
After a low battery event the stock 2009 Navi unit is acting up. The screen displays a "no DVD map in unit" message and it can not be removed. I am sure the map is inside but can not eject it. Any ideas on how to reset the unit? The radio, CD, i-POD works but can't change the screen or eject CD/map DVD. Thanks.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #2
OK, this is what happened and what I did.
When starting the car with a very low batter the Navigation data disk in the unit jammed. The unit thought there was no disk and asked to load one. Since the disk was kind of jammed, when opening the face of the unit the disk could not be ejected.
I did remove the unit, remove the mounting brackets, the top cover and then the front face (black plastic). I did re-apply power with the front face kind of hanging down and this time the disk ejected (you have to press the LCD display at the top right corner to eject the disk)..
I then found out that I had to re-load the unit with some basic software (in disk n. 1), like when the first time the dealer did. Then it worked fine, after I put everything back together:lol:
 

·
Registered
Joined
·
7 Posts
OK, this is what happened and what I did.
When starting the car with a very low batter the Navigation data disk in the unit jammed. The unit thought there was no disk and asked to load one. Since the disk was kind of jammed, when opening the face of the unit the disk could not be ejected.
I did remove the unit, remove the mounting brackets, the top cover and then the front face (black plastic). I did re-apply power with the front face kind of hanging down and this time the disk ejected (you have to press the LCD display at the top right corner to eject the disk)..
I then found out that I had to re-load the unit with some basic software (in disk n. 1), like when the first time the dealer did. Then it worked fine, after I put everything back together:lol:
Thank you man. I really appreciate that you shared your experience. Same thing happened to me today and thanks to you, I solved it without having to visit the dealer.
Actually, I didn't even have to remove the unit. I just pressed the top right corner to eject the disk and inserted the subaru disk A in order to re-load the software.

Many many many thanks!!!
 

·
Registered
Joined
·
1 Posts
I am so grateful for this post. I disconnected my battery to change a bulb in my 2010 Impreza and got the dreaded "No DVD map in unit, please insert Disc" With no way of ejecting the DVD I was beyond puzzled. The front of the unit would rotate and that was all it would do. Then I tried pressing the top right hand corner of the screen and bingo....out popped the map DVD. I think it was the first time I had disconnected the battery since I replaced the map DVD for a new updated map DVD bought on eBay. Maybe this is the problem? I have now reinserted the original Subaru DVD and all is well again. Thank you again to whoever posted that "fix" Cheers Tim from the UK
 

·
Registered
Joined
·
3,132 Posts
this must have changed in later models and now use an SD card.. when i ejected that to replace it with my own music filled card, maps no worky.,
 
1 - 5 of 5 Posts
Top