IW STi Forum banner

1821 - 1840 of 1860 Posts

·
Registered
Joined
·
1,956 Posts
Discussion Starter #1,823
Had an ancient lady take a left hand turn from the main drag onto my road while I was pulling up to the stop sign and she decided to turn into my lane (opposite direction) and I had to take emergency actions which resulted in my car promptly throwing CEL / P0031.

Recognized that code as the O2 sensor (not the first time), suggesting maybe my wiring was a bit loose. Took two reflashes and looked through the engine bay but everything seemed ok. Got it to go away for now and stayed away for a day. Will keep my fingers crossed.
 

·
Registered
Joined
·
907 Posts
Had an ancient lady take a left hand turn from the main drag onto my road while I was pulling up to the stop sign and she decided to turn into my lane (opposite direction) and I had to take emergency actions which resulted in my car promptly throwing CEL / P0031.

Recognized that code as the O2 sensor (not the first time), suggesting maybe my wiring was a bit loose. Took two reflashes and looked through the engine bay but everything seemed ok. Got it to go away for now and stayed away for a day. Will keep my fingers crossed.


Did you unplug the sensor and plug it back in?

Kind of a weird code to throw in that situation. Did the car go into limp mode or just got a check engine light?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
1,956 Posts
Discussion Starter #1,826
And now I'm getting strong noise / vibration from my rear brakes and the brake pedal. Will have to see what's up with that. And I didn't put my summer wheels on yet though its been freaking in the 40s while driving so :/
 

·
Registered
Joined
·
170 Posts
Ok, I have officially had my tampering flag removed :)

My car has officially passed inspection once again and I'm good for another 18 months (normally 24 months but it took 6 months to get this far :/ )

And I should be good and ready to go when the time rolls around once again.

Also got my oil changed at a new place... will admit I let them put in a brand I never heard of before but the owner does have an STI albeit the shop works mostly on Ferraris and Porsches. But the guy seems to know what he's doing :)

So now that I don't get death stares for the big red sticker, perhaps I can finally get that e85 tune though now maybe I should just wait till next season :/ Not sure what the e85 quality is now.


Hey maz, quick question: what did you do to get this resolved? I just got rejected because apparently (1) the car came from the factory with 2 cats and they only see one and (2) the cat on the dp apparently needs to be stamped and they could not see the stamp...
 

·
Registered
Joined
·
1,956 Posts
Discussion Starter #1,828
I literally swapped a friend’s stock setup for the day :/


Sent from my iPhone using Tapatalk
 

·
Premium Member
Joined
·
5,202 Posts
I just got rejected because apparently (1) the car came from the factory with 2 cats and they only see one and (2) the cat on the dp apparently needs to be stamped and they could not see the stamp...

I've never had a problem. I think many shops will pass you with one. Just go to a different one with no sticker.
 

·
Registered
Joined
·
907 Posts
Our cars didn’t come with 2 cats, go to another shop. And if you have to, put the stock down pipe back on.


Sent from my iPhone using Tapatalk
 

·
Vendor
Joined
·
5,400 Posts
Our cars didn’t come with 2 cats, go to another shop. And if you have to, put the stock down pipe back on.
Yes they do. One in the top and one in the bottom section of the 'downpipe'.
 

·
Registered
Joined
·
1,956 Posts
Discussion Starter #1,833
Here is the problem with going to another shop: NJ has a tampering flag. If they flagged you for tampering you cannot go to private inspection and get it cleared. That’s why I had to go to such extremes.


Sent from my iPhone using Tapatalk
 

·
Premium Member
Joined
·
5,202 Posts
I checked this too. Been so long since I had two cats I forgot! I saved mine for a long time - but since it passed inspection numerous times I think I tossed it years ago. Pre garage it was outside rusting away These days i'd find a place to hang it.
 

·
Registered
Joined
·
1,956 Posts
Discussion Starter #1,836
Ok so on Saturday went to Prime.

So, first things first:
A bolt broke on a rear caliper. Some meat left on it (it apparently broke deep in) so they were able to still attach it but now I'm going to have to replace it eventually. I'm guessing just finding a used one or maybe seeing if someone can heli coil it. Sort of aggravating as the reason I don't do my own brakes is to avoid that. Otherwise, very happy with the new brakes but I must admit I preferred my Project Mu pads to these Stoptechs so far but maybe I just need to bed them in but was hesitant due to the bolt. On the other hand, these brakes are notorious for having that happen so c'est la vie.

Prime added a heatsink bung to my header to hopefully help prevent me from burning out more front O2 sensors. That plus new O2 sensor all done.

New spark plugs.

Oil change. So far, so good. Was scared by the local shop I used as I'm fairly certain they didn't use synthetic on the last change.

So things Prime noticed: my AF Corr 1 is apparently a bit wonky. Not sure if that's a new thing or not as I don't monitor AF Corr 1. I'm presuming Shinji can check it out when we get together next. Should probably arrange to finish my e85 tune with him soon.

One thing I've had problems with is my startup. I've had to give the car gas sometimes to get her started but not when I'm parked on an upward sloping incline it appears so not sure if that's just random or what and its certainly not every start but it happens.

Car is running just fine otherwise.
 

·
Registered
Joined
·
1,956 Posts
Discussion Starter #1,839
They didn’t even offer it as an option and was sort of shocked myself.


Sent from my iPhone using Tapatalk
 
1821 - 1840 of 1860 Posts
Top