IW STi Forum banner
1 - 17 of 17 Posts

·
Registered
Joined
·
601 Posts
Discussion Starter · #1 ·
I don't really know why but it seems like my intercooler spray is not working, I press the button many times and I hear the sound of the motor, but don't see any water come out of the sprayer.

Does anyone know what the problem can be??

I'm gonna take a look at the tank more carefully tomorrow and see if something is lose??
 

·
Registered
Joined
·
601 Posts
Discussion Starter · #3 ·
kessler89 said:
i'd check the nozzle and make sure it and the check valves aren't clogged ;)
good idea, it might be the nozzle, thx :)
 

·
Registered
Joined
·
601 Posts
Discussion Starter · #4 ·
nothing is stuck, I checked the nozzel and it looks perfect, I think it might be my actual pump :(
 

·
Registered
Joined
·
402 Posts
orA HOSE is disconnected somewhere, look on top of the trunk where it runs...mine got caught under the hood on my brace and came apart also before, it just running out somewhere is my guess...trace the lines...
 

·
Registered
Joined
·
1,713 Posts
ammarX786 said:
nothing is stuck, I checked the nozzel and it looks perfect, I think it might be my actual pump :(
well if you can hear it making it's "buzz" sound when you hit the switch, you're pump is working, there's a little round check valve just before your nozzle take it off and blow through it and make sure it's not clogged, my i/c sprayer i had on my old 03 wrx clogged up all the time, now i only use drinking water/distiled water
 

·
Registered
Joined
·
601 Posts
Discussion Starter · #7 ·
Fixed :d

kessler89 said:
well if you can hear it making it's "buzz" sound when you hit the switch, you're pump is working, there's a little round check valve just before your nozzle take it off and blow through it and make sure it's not clogged, my i/c sprayer i had on my old 03 wrx clogged up all the time, now i only use drinking water/distiled water
FIXED!!! yeah it was clogged. I took the valve out and blew thru it and also poked a paperclip thru the nozzle and it started to work, I had no idea that the nozzle could get clogged like that.

Thanks man :tup:
 

·
Registered
Joined
·
896 Posts
Zach STI said:
Quick question, where is the I/C water spray tank located? :p
The passsenger side of the trunk. There is alittle cover in the panel that you pick up, and the cap for the resevior is right under that. :rtfm: ;)
 

·
Premium Member
Joined
·
4,591 Posts
In the right sine of the trunk. Little flap that matches the rest of the trunk lining. Pop it open and fill er up. BTW the owners manual tells all.
 

·
Registered
Joined
·
8,266 Posts
If you have an air compressor, blow through the nozzle with the air attachment. Thats how Ive fixed my clogged nozzle.
 

·
Registered
Joined
·
569 Posts
sometimes they get installed backwards too

and that would stop the flow of water.
 

·
Registered
Joined
·
202 Posts
oh crap... i would fill the wiper tank all the time... thanks

i have a friend that uses his wiper tank to cool his I/C on his wrx and puts in half water and half ice, will it be alright to do the same thing?
 
1 - 17 of 17 Posts
Top