IW STi Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi all, I installed the idoing HU in my 2020 sti base today and everything works fine except that I'm not getting sound out of my front driver side speakers. The speakers aren't blown because when I tried using the SOS function from starlink, audio was coming out from the speakers... it's only when I turn on music I lose audio on my front driver side.
 

·
Registered
Joined
·
13 Posts
Great thank you. Can you tell me one more thing, the part no. perhaps? I looked on that site but had a hard time narrowing down which one I needed. (although one listing I saw said 2016+ which is odd. I have a 2015, not sure why that wouldn't work?)
I got mine for my 18 sti from WRXdaily, it took about 2-3 weeks to get. It was also very easy to figure out which you needed as it broke them down by Iphone/ android and year of vehicle
 

·
Registered
Joined
·
130 Posts
Hi all, I installed the idoing HU in my 2020 sti base today and everything works fine except that I'm not getting sound out of my front driver side speakers. The speakers aren't blown because when I tried using the SOS function from starlink, audio was coming out from the speakers... it's only when I turn on music I lose audio on my front driver side.
Hmmm...I have one of these also and didn't have this issue. Are you sure you plugged everything the correct place?
I highly recommend checking this video out since I also used it for the install and watching where he plugs everything in. Made it super easy and like I said, I didn't have this issue.

Also, might matter if your on the base audio, or Harmon Audio.

Great thank you. Can you tell me one more thing, the part no. perhaps? I looked on that site but had a hard time narrowing down which one I needed. (although one listing I saw said 2016+ which is odd. I have a 2015, not sure why that wouldn't work?)
For 2015, you need a different one. I forget why....though...you can search it up on youtube.
This is where I bought mine, the official seller. He has the 2015 one also, just need to find it on his page.

 

·
Registered
Joined
·
4 Posts
on the 2015’s the backup camera shows on the MFD instead of the head unit…i had to buy an adapter harness for it to show up on a aftermarket head unit


Sent from my iPhone using Tapatalk
 
1 - 7 of 7 Posts
Top