IW STi Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
My driver side oil control valve keeps leaking after replacement of the whole thing and a new gasket it leaks through the bolts I even got new bolts for it but nothing changed. It's on the driver side next to the header. This is what it looked like before I replaced messy and dirty I don't have pic of replacement right now but it just leaks through the bolts now.
Jaw Helmet Font Automotive tire Event
 

·
Registered
Joined
·
252 Posts
I just replaced the same part a few days ago. Thanks to thread here at iwsti:


Looking at old part the 4 holes through which the 4 bolts go through are not connected to the oil tracks at all.

I would presume oil can only seep through to the bolts via the valve/cylinder head mating surface. The tightening torque of these 4 bolts is about 7 lb/ft. May be you could reinstall it again and see how it goes.

Also I cannot see from your picture. Is the ground strap fitted to the 5th, shorter bolt as it is supposed to?

Hope it works out for you.

cheers
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
I just replaced the same part a few days ago. Thanks to thread here at iwsti:


Looking at old part the 4 holes through which the 4 bolts go through are not connected to the oil tracks at all.

I would presume oil can only seep through to the bolts via the valve/cylinder head mating surface. The tightening torque of these 4 bolts is about 7 lb/ft. May be you could reinstall it again and see how it goes.

Also I cannot see from your picture. Is the ground strap fitted to the 5th, shorter bolt as it is supposed to?

Hope it works out for you.

cheers
Alright I'll see what you suggested and the ground is strapped to the ground spot that's supplied on the ocv
 

·
Registered
Joined
·
252 Posts
Ah sorry I missed in your original post the picture is from before replacement .

Good luck and hope to hear succesx from you soon!
 
1 - 4 of 4 Posts
Top