IW STi Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
307 Posts
It cost me $200 to have it done by my local audio shop. Becasue of all the money I have spent there the cut me good breaks on a lot of other stuff now though.:D
 

·
Premium Member
Joined
·
8,137 Posts
u can do it urself, its not that hard at all
 

·
Registered
Joined
·
311 Posts
Its pretty easy install. The newer kenwood is super easy.
 

·
Registered
Joined
·
180 Posts
normally that'll cost you about 2 hours of labor if shop has to do all the wiring stuff on double din navi/dvd. is always better off if you buy it used from a WRX or STI that has the wiring all done, and all you will need to do is plug in and connet the speed wire, which took me less than 20 mins.
 

·
Registered
Joined
·
1,552 Posts
^exactly what I did. Except finishing off rest of the system took like 2 days... haha.
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #9 ·
wow, so the labor is not that expensive.

what about the parts? i heard they cost around $2000ish
 

·
Registered
Joined
·
181 Posts
Im having probs with my Apline iva w200. everytime i turn the lights on, the screen goes to rear camera view. oblviosly faulty wiring on my part but i didnt have a manaul and i cant figure out which wire it is. all i did was match all the wire from the system to the harness i bought at best buy. any help would be great
 

·
Registered
Joined
·
149 Posts
i recommend taking it to a professional. That sounds like your best. I wouldnt go mix matching wires and take the chance of blowing the wrong thing.
 

·
Registered
Joined
·
311 Posts
Im having probs with my Apline iva w200. everytime i turn the lights on, the screen goes to rear camera view. oblviosly faulty wiring on my part but i didnt have a manaul and i cant figure out which wire it is. all i did was match all the wire from the system to the harness i bought at best buy. any help would be great

I have no experience with that model but most alpines I have seen had a wiring diagram sticker on the top of the units. A easy way to fix it is to use a test light or a multi meter and find which wire gets hot when you turn the lights on and disconnect it. I can't tell you right off what color the wire is to dim the unit but I can look at one of my alpines when I get home and let you know what it is and maybe yours is the same. Let me know if you want me to do that. Ritchie.
 

·
Registered
Joined
·
1,464 Posts
my local shop put mine in for 90$
 
1 - 14 of 14 Posts
Top