IW STi Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
508 Posts
Discussion Starter #1
Well I have my blue power antenna wire hooked up go to the antenna amplifier, but my radio reception is still pretty spotty. In the front range of Colorado I can only get maybe two AM stations at all, and common stations such as 97.3 and 93.3 that I have always received well in other cars come in out of reception as I am driving. Is this a function of the in-glass antenna or am I missing something in my wiring? I grounded through the harness instead of direct to the chassis FWIW. I also tried a new head unit with no change so I know that isn't it.

Let me know if I need to pull everything apart again or just get used to listening to CDs. :roll:

Thanks,

Nick
 

·
Premium Member
Joined
·
2,802 Posts
My reception sux also. I get some of the strong FM stations and most AM but they are no where near as good as they were in my old Legacy. I am eventually going to get XM.
 

·
Registered
Joined
·
260 Posts
calling all NJ, NY, PA, DE and NJ WRX owners...

yep, sucky is the word. FM is spotty and if I scan on AM I don't usually stop on any stations but if I manually tune to them, I'll get reception. I'm running the alpine 9815.
 

·
Registered
Joined
·
347 Posts
loving this snow...

i plugged the antenna wire right into the back of my sony, and if i give my old car (w/ bosch antenna) a 10, the subie is 8+. there are only a few spots where the reception seems to suffer, and they don't last but a few seconds.
 

·
Registered
Joined
·
949 Posts
my reception on my eclipse with tinted rear window is not very good.
tint supposedly has some effect if it's metallic.
i mainly listen to cd's now because reception is pretty bad.
my g/f has an eclipse on her 02 civic w/ windshield antenna and it sux also
 
M

·
Guest
Joined
·
0 Posts
Eclipse/JL Audio System...

hmm
I haven't noticed any less reception quality in mine, but after getting xm, I don't ever listen to it anymore but.... on a recent road trip, I was able to get an AM station for over an hour after I left the broadcast area. That's as long as I was able to keep reception of that same channel in either of my other cars.
 

·
Registered
Joined
·
694 Posts
Wait, this HU has a radio...?! Gee, I hadn't noticed since I wired up my iPod. ;)
 

·
Registered
Joined
·
52 Posts
FS-JIC FLTA2

I just got finished installing a 9815 Alpine and have the same problem, fm is fine but no am. I even hooked up the blue power ant wire and the black coaxial that was in the dash directly to the head unit coaxial. I do have tinted windows with metallic. Really need my local sports talk am radio, anybody have any other suggestions besides satellite. :cry:
 
M

·
Guest
Joined
·
0 Posts
Re: Does U.S. Sti deserve respect?

My windows are also metallic tinted so that is not it. My HU is the 9813 so they are pretty close.

Even though you said 'not xm', if you are a true sports radio fan, you will love XM, there are like 5 sports talk channels inlcuding espn and foxsports. :)
 

·
Registered
Joined
·
378 Posts
LVSTi said:
I just got finished installing a 9815 Alpine and have the same problem, fm is fine but no am. I even hooked up the blue power ant wire and the black coaxial that was in the dash directly to the head unit coaxial. I do have tinted windows with metallic. Really need my local sports talk am radio, anybody have any other suggestions besides satellite. :cry:
Same here with the 9815. FM seems to be fine, but I never listened much to FM before so I'm not sure if I got more or less stations. As for AM, it stops on a few AM stations if I scan, but there isn't any sound. I thought maybe it was a setting or my wiring, but i guess that's not the case. :( I have 35% tint but it's not metallic.
 

·
Registered
Joined
·
85 Posts
i just got my oem stereo installed at the dealer and i am satisfied with the sound. reception is great and the under seat sub can actually be heard and felt pretty good :D i was pleasantly surprised. i want to tint the windows, and i wonder if anyone has ever had their window-printed antennas 'clipped' by the tint installer and then get crappy reception? i know they use a blade to trim the tint. is it possible they can damage the antenna/defroster in the process? it sounds humanly possible imho. now i'm afraid to get the windows tinted :eek:
 

·
Registered
Joined
·
694 Posts
saltypalm said:
is it possible they can damage the antenna/defroster in the process? it sounds humanly possible imho. now i'm afraid to get the windows tinted :eek:
Anything's possible! I'd suggest mentioning it to them as a concern when you drop the car off to have it done, and choose a reputable tinting shop. Locally, Ziebart comes very highly recommended by a lot of people.

Should the worst happen, remember that they'll be replacing the damaged bits of your car, on their dime. No worries.
 

·
Registered
Joined
·
36 Posts
Hey, STI in Evergreen CO. 9815 HU with antenna hook up to rear window. Typical front range reception, no better, no worse than 02 WRX I traded in for STI. People raving about Sirus however, so I'll probably go to that eventaully
 

·
Registered
Joined
·
949 Posts
well, i took my car to tweeter to check my deck and they found that the idiots who did my install @ another shop forgot to power the internal antenna.
now i have radio again!
it's not bad @ all imo.
 
1 - 15 of 15 Posts
Top