IW STi Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
342 Posts
Discussion Starter · #1 ·
I had my deatschwerks 740cc injectors installed today. These are modifed stock injectors.
http://www.deatschwerks.com/subaru.htm

Since these are modified stockers and according to tuning manual which christian provided me, modified stockers should use the stock latency table. I did my calculation for the injector scaling value: (500/740)*5372 = 3629

When I put 3629 in to ST the car runs very lean! The short term trim values are up in the 20s. I can bring the trim values down by using a larger scaling number (4650) but the afrs are a bit off. After reading a few threads I decided to use the 3629 number for the scaler and then adjust the latency values. I found wolfplayer's latency values for his stock injectors and used those as starting values. After playing with the values a little bit I got the trim values down. I went for a drive and weird things are happening...

When I go in to boost (about 5psi) my wideband says its still in the 14s! I was getting knock while going in to a bit of boost in 5th at part throttle. My knock light flickered a bit so I let off and pulled over to see the knock correction table and DAM.. My DAM was down to .88 and I had several small negative correction values in the knock correction table.

I would post up a complete log but my LC-1 has gone crazy. The serial connection does work but the analog out still works and feeds info to my scan master 3.

I'm running a APS 65mm CAI which I had tuned pretty well prior to the injector install...
 

·
Registered
Joined
·
400 Posts
If you still have the stock air box put it back on. That will help you out a lot. I did that for my JECs. Other than that I don't know exactly but I will think.
 

·
Registered
Joined
·
342 Posts
Discussion Starter · #3 ·
I think I may put the stock intake in just to verify the size of the injectors. The injectors did come with flow test paperwork and the IDCs are definitely lower than before though. Using the stock intake calibration I had to add 25% to almost all values. I ended up adding 25% (M+1.25) to the whole table but I ended up with high voltage values of over 300 grams. This can't be right... ??
 

·
Registered
Joined
·
400 Posts
How were your trims after calibrating? did you just multiply stock by 1.25? I wouldn't think that that would be the best but I could be wrong. When you are idling where do you idle on the afr range?
 

·
Registered
Joined
·
342 Posts
Discussion Starter · #5 ·
At idle the car was bouncing between 14.2-15.0.

Yes, I multipled the stock by 1.25 which I know is bad but the intake calibration was that off. I don't think it should ever be that off.

sti752 said:
How were your trims after calibrating? did you just multiply stock by 1.25? I wouldn't think that that would be the best but I could be wrong. When you are idling where do you idle on the afr range?
 

·
Registered
Joined
·
400 Posts
I would recommend putting the stock airbox on and trying to follow the tuning guide starting with the stock latencies. Also, use the given scaler for 720cc/740cc inj like jec or nismo (3625). See where that gets you. Hope I'm helping a little bit.
 

·
Registered
Joined
·
342 Posts
Discussion Starter · #7 ·
Yep, I'm putting the stock box back on tonight. This is pretty frustrating and I kind of wish I did the injector install myself so I know they were installed right. I got lazy and paid a shop to do it.

sti752 said:
I would recommend putting the stock airbox on and trying to follow the tuning guide starting with the stock latencies. Also, use the given scaler for 720cc/740cc inj like jec or nismo (3625). See where that gets you. Hope I'm helping a little bit.
 

·
Registered
Joined
·
400 Posts
For future reference the injector install is not too bad. I know that doesn't help you know but oh well. Also, there is a right up on installing the JECs that tells which is the power wire to injector and which is the ground wire. So, maybe just to check you could look that up and then visually inspect your injectors.
 

·
Registered
Joined
·
342 Posts
Discussion Starter · #9 ·
Wiring shouldn't be a issue since the Deatschwerks 740s I have are fancy modified injectors. The guys at Deatschwerks have confirmed that the latency values should be the same as stock. The injectors use the stock clips.

Well, I may end up pulling the injectors and throwing the stockers back in...

sti752 said:
For future reference the injector install is not too bad. I know that doesn't help you know but oh well. Also, there is a right up on installing the JECs that tells which is the power wire to injector and which is the ground wire. So, maybe just to check you could look that up and then visually inspect your injectors.
 

·
Registered
Joined
·
342 Posts
Discussion Starter · #10 ·
So I put my stock airbox back in and used the stock intake calibration table. To get the trims back in line I again had to use a scaler number in the 4000s. I think I ended up using 4410. Are these injectors actually just smaller than advertised? A lot smaller?
 

·
Registered
Joined
·
400 Posts
Dang, it seems like they really are smaller. You should talk to the company about that. It really does seem like something is wrong with them.
 

·
Registered
Joined
·
342 Posts
Discussion Starter · #12 ·
What is really scary is that the injectors came with paperwork showing each injector was flow tested and are 740cc. There is a part of a puzzle missing. Could the injectors being installed incorrectly have caused this? The car idles and drives fine in closed loop.

sti752 said:
Dang, it seems like they really are smaller. You should talk to the company about that. It really does seem like something is wrong with them.
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top