IW STi Forum banner
1 - 6 of 6 Posts

Registered
Joined
18 Posts
Discussion Starter · #1 · (Edited)
Hi all, I wanted to reach out about an issue I'm having in case anyone has any ideas (before going to the dealer). I was running an errand today and had my iphone hooked up to the headunit and playing music over Apple CarPlay. Everything was fine as usual until I heard a super loud alert like tone and the head unit seemed to freeze, then finally rebooted itself. I've googled around a bit and have seen mentions of navigation alerts, but I didn't seen anything in the settings, also, that should not cause the head unit to freeze and reboot if that were the case.

Another piece of information is that I just installed (a few days ago) a Cobb Accessport V3 and stage 1 tune, which is awesome by the way. However, maybe I could be wrong, but the tune and changes to the ECU should not be mucking with the head unit functionality right? When I got home, I shut it off, disconnected the accessport (OBD2 cable still attached) and tried to reproduce and was able to get the loud single tone, unit freezes and then a reboot. Super weird. I'm not sure what could be causing this, but wanted to see if anyone had run into this or had any pointers/thoughts.

Update 3/30/2022: The head unit issues had nothing to do with Cobb/Stage 1 tune...it's a known issue(s) with these head units. If the dealer is unable to reproduce the issue(s), you should just make a video recording of the issue to use as evidence for a warranty claim - this should at least get you replacement components.

Thanks!

Note: 2019 STI Limited and I'm confident the head unit firmware is relatively up to date...within a year or so, since it was freezing on me differently (no loud beep) a year ago and the dealer updated the firmware.
 

Registered
Joined
18 Posts
Discussion Starter · #2 ·
Got a response from Cobb and they confirmed that the Accessport has nothing to do with it. Support also mentioned that it's likely related to all the issues people have been having with them lately:
62138


To the dealer it goes...lame sauce. Maybe they'll refund me some of the head unit costs and I can just go aftermarket 馃槀馃槀馃槀 /s
 

Registered
Joined
18 Posts
Discussion Starter · #3 ·
Update: went to the dealer (my 2nd time bringing this issue up at a service appt) and they couldn't reproduce the issue. The service rep said to try and record it so that they could submit it to Subaru of America for a warranty claim. I'm not sure if that'll mean head unit replacement or paying me off to keep me appeased LOL, but we'll see. I was actually able to record a few clips of the head unit kept rebooting itself while playing music over CarPlay the other day. The music was also super staticky at one point, so the head unit or something is super FUBAR. At this point, I'd rather get a few $K and just go aftermarket or something, but we'll see how it plays out.

Looks like this is a known issue with these crappy headunits since Subaru has been sued:

"Subaru Slapped With Another Lawsuit; Have You Had Starlink Problems?"
"Subaru Starlink Lawsuit - New $6.25 Million Agreement Benefits 785,000 Owners"
 

Registered
Joined
1 Posts
Update: went to the dealer (my 2nd time bringing this issue up at a service appt) and they couldn't reproduce the issue. The service rep said to try and record it so that they could submit it to Subaru of America for a warranty claim. I'm not sure if that'll mean head unit replacement or paying me off to keep me appeased LOL, but we'll see. I was actually able to record a few clips of the head unit kept rebooting itself while playing music over CarPlay the other day. The music was also super staticky at one point, so the head unit or something is super FUBAR. At this point, I'd rather get a few $K and just go aftermarket or something, but we'll see how it plays out.

Looks like this is a known issue with these crappy headunits since Subaru has been sued:

"Subaru Slapped With Another Lawsuit; Have You Had Starlink Problems?"
"Subaru Starlink Lawsuit - New $6.25 Million Agreement Benefits 785,000 Owners"

Hi! Did you ever figure out how to fix this issue? I am having the exact same problem and the dealership isn't helping at all - they said they have to be able to recreate the issue but haven't been able to. I'd really appreciate any advice you can give, thanks!
 

Registered
Joined
18 Posts
Discussion Starter · #5 · (Edited)
Hi! Did you ever figure out how to fix this issue? I am having the exact same problem and the dealership isn't helping at all - they said they have to be able to recreate the issue but haven't been able to. I'd really appreciate any advice you can give, thanks!
My dealership could not reproduce the issue also, however, they recommended I make a recording of the issue so that they could use that as evidence for a warranty claim with Subaru of America. I did that, although it was tricky with the iphone plugged in. Sometimes my wife would record it when it happened while driving. So I'd recommend doing that and getting a replacement.

Note that for my case, I went through several different replacements and they all eventually had similar issues - it's unfortunate because it's a decent deck/sound system otherwise...on the Limited at least. You may have better luck than I did with replacements though - so I'd record and request a replacement of the deck/amp. I'm sending you a DM.
 

Registered
Joined
1 Posts
Hello,

Glad I'm not alone.
I bought my Impreza 2022 two month ago and that happened twice.
I never be able to record it because it happened when I was driving on the freeway in the night...
I am now thinking to buy a dashcam with inside camera... the beep was super loud and scared me!
 
1 - 6 of 6 Posts
Top