IW STi Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
123 Posts
Discussion Starter · #1 ·
Well i woke up today and got in my car to start it. I couldn't believe when i saw the engine light on and cruise control flashing. I do in fact baby this car and the day before was the only time i rode her close to redline. (like 5 times) the car didnt seem weird or anything when i started her or while idle, it rode perfect. After freaking out. i jump back in my car after talking to my GM and as soon as i turn my car on. Bam..... No engine light or curise control flashing. My question to is should i be concern is there anything wrong? thanks in advance.
 

·
Registered
Joined
·
333 Posts
take it in and get the stored codes read at a Suby dealership or Autozone or some place like that. then you will know what the CEL was for and whether or not it's something to worry about. i had a CEL once, cylinder 4 misfired when i started up and it threw the CEL, but IIRC the CEL stayed on until i had the codes read and cleared.

the first thing the Suby dealership told me when i called them about the CEL was to make sure the gas cap was tight.
 

·
Premium Member
Joined
·
4,120 Posts
What you just experienced is called a "pending code". That is normal, the ECU saw something that was out of parameter and stored it as a pending code. The ECU later cleared it and thats why you dont see the alert any longer. You wont be able to pull the code now because it is gone... Just keep an eye on things but the ECU is acting as it should!
 

·
Registered
Joined
·
123 Posts
Discussion Starter · #4 ·
wheww......cool what about the flashing cruise control both were on and off at the same time. It just seem really weird that both came on and off.
 

·
Registered
Joined
·
286 Posts
the cruise flashes when the mil is on on a subaru...thats just a failsafe. sort of like a limp in mode. also, atuozone and places like that might not be able to find the code now that the light is off, but subaru will. the fault has to be recorded somewhere in freeze frame or in a simple one trip detection monitor...but its in there, somewhere.

-corey
 

·
Premium Member
Joined
·
4,120 Posts
actually it is not. Subaru wont be able to find it either..... Pending codes are never really written anywhere, thats why it cleared it self....It is common for both the cruise and the check engine to on during some codes....
 

·
Registered
Joined
·
333 Posts
is a pending code different from a stored one? when i had my CEL i watched the guy at Subaru read the codes. first he went to "Read Codes" and there were none. then he went to "Read Stored Codes" and it showed the misfire code.
 

·
Registered
Joined
·
286 Posts
2fas4u said:
actually it is not. Subaru wont be able to find it either..... Pending codes are never really written anywhere, thats why it cleared it self....It is common for both the cruise and the check engine to on during some codes....
\

well subaru must me worlds different from chrysler, dodge, jeep, and all general motors products (all though i cant see how). usually anytime a customer brings a car in here with the same complaint the code is always stored. maybe not in the engine dtc section, but ususally in some sort of freze frame data. im not saying they can hook their scan tool up to the car and scan dtc's and find the history of the light...but im almost sure that its in the cars memory somewhere. but i have been wrong before :p
 

·
Registered
Joined
·
286 Posts
jomotopia said:
is a pending code different from a stored one? when i had my CEL i watched the guy at Subaru read the codes. first he went to "Read Codes" and there were none. then he went to "Read Stored Codes" and it showed the misfire code.
yes it is different. first off a pending code is one that is causing the ecu to turn on the mil....malfunction indicator lamp. a stored code is what we have in this thread...a case where the car recorded a sample of data out of its preprogrammed parameters. so it threw on the mil for a short amount of time untill it runs the monitor that orginally set the light...at that time when it sees that everything is working properly it shuts off the light, but it will store the code. atleast that is what i have been taught.

-corey
 

·
Premium Member
Joined
·
4,120 Posts
the only reason I said that was during my GT30R install we saw a few pending code situations and after they cleared the Cobb AP was not able to detect them. So I really should have said that Suby could'nt find them, maybe it was an Access Port issue only....
 

·
Registered
Joined
·
286 Posts
2fas4u said:
the only reason I said that was during my GT30R install we saw a few pending code situations and after they cleared the Cobb AP was not able to detect them. So I really should have said that Suby could'nt find them, maybe it was an Access Port issue only....

ahhhh who knows, maybe i think AP's only read active codes. i just wanted to help the guy who orginally posted....ohh and btw gt30r FTW!!!!:tup:
 

·
Premium Member
Joined
·
4,120 Posts
ImprezivSTi04 said:
ahhhh who knows, maybe i think AP's only read active codes. i just wanted to help the guy who orginally posted....ohh and btw gt30r FTW!!!!:tup:
Woot!!
:tup: :lol:
 

·
Registered
Joined
·
123 Posts
Discussion Starter · #13 ·
thanks guys.....im gunna take it to the dealership and see what they say.....i know it nothing but better safe then sorry
 

·
Registered
Joined
·
652 Posts
I have my 05 STi at the dealer at this exact moment for 30k service and to check the engine for a code i pulled know as p0303 (misfire in cylinder 3). About 1k miles before i have had a fuel injector go out. So i have experienced the CEL on and off. Just take it to the dealer and have them fix it. If you have babied it and if i have done auto-x, rally-x, drag, and hard driving then you should have no problems with the dealer.
 
1 - 14 of 14 Posts
Top