IW STi Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter #1
Has anyone who received the cars off the first allocation of STIs for New England had problems with detonation such as seen in SOA allocation cars? I picked mine up in VT last Thurs. and have 1100 miles. I have not experienced any pinging. I have only run Sunoco 94 and Mobil 93, though this does not seem to make a difference with the other detonation cases.
 

·
Registered
Joined
·
1,549 Posts
STi in KC!

Picked mine up last Friday, put on 50 miles and had to leave the country the next day!! Heard no pinging then, and I was pushing to 4-5k rpm (first dealer fillup was 93 octane). Hope to put some real miles on this week, but so far so good...

BUT - I don't think the people on this board took the time to read their manual (I had time on the 8-hr flight). Subaru knows all about the pinging, and even documented it in the manual!! They put it in print before we got our cars - slight pinging in extreme cases is to be expected, and don't worry about it. Right or wrong, they already printed their disclaimer. Don't hold your breaths for an official fix...
 

·
Registered
Joined
·
2,773 Posts
exhaust

I wouldn't call the cases of pinging that some people are getting either extreme or 'rare', quoting the manual.

Official or not.....there will be a fix. I'm willing to bet the tuners have it fixed before Subaru ever worries about it...which is unfortunate. All we can do at this point is document the cases. When enough calls get through to the tech line, someone will start wondering what's up. I'd like to think Subaru would think twice before swallowing a pill like allowing it's halo car to have engine issues.....but as you mentioned....don't hold your breath.
 
1 - 4 of 4 Posts
Top