IW STi Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
58 Posts
Discussion Starter #1 (Edited)
I have a 08 sti, 30r turbo forged pistons 850 fuel inj, Top mount inner cooler, 446 whp. 70000 miles on this build. This Just happened engine runs perfect up to about 8 or 9 psi and then I get #1 cyl miss fire. It is not rpm related I can go to redline as long as I don't go over that 8 or 9 psi. Fuel pressure stays good, AFR stays good.

Any thoughts.
 

·
Registered
Joined
·
3,518 Posts
well, first of all, congrats on getting 70,000 miles on a 446WHP build. I, for one would like to know your recipe for success.
 

·
Registered
Joined
·
58 Posts
Discussion Starter #3
Simple I don't beat on it all the time. Good tune,That was at 30 psi, I run it at 23 most of the time. I keep a eye in oil pressure, temp, Afr. Stock short block CP pistons Mod oil pump. Its burning oil now. I have a new short block ready to go using Manley A B pistons.
 

·
Registered
Joined
·
2,869 Posts
Good quality gas goes in it I assume.

I'd pull the plug and coil pack and swap it over to cylinder 3 and vise versa....See if it follows it, then its either the plug or coil pack. I'd also check the gap on them...

I had a coil pack go bad on me and would miss under boost only, as well. Same with a friends sti.

Report back
 

·
Registered
Joined
·
1,509 Posts
I will second/third spark plug gaps, once you start cramming the air in the cylinder is when proper gaps becomes crucial.
 

·
Registered
Joined
·
2,869 Posts
Mine also popped like crazy when the gap was at 34...

32 fixed it, 28 made it pull noticeably harder, so then i tried 26 but their was no difference so I stuck with 28.
 
1 - 8 of 8 Posts
Top