IW STi Forum banner
1 - 5 of 5 Posts

·
DirtyImpreza.com
Joined
·
821 Posts
Discussion Starter · #1 ·
Sup everyone.

So i installed my Cusco front strut bar, and it looks great. However the instructions left me with a hanging AC line because they dont make sense. Let me explain:

Heres the instructions:

indicated in red is the part where you are supposed to remove the "cushioning rubber" from the OEM AC support bracket. However there is no way to remove it since it is actually fused to the bracket (i ended up ripping it in half)

Ripped "cushioning rubber":


Original location of bracket:


So, my question is... where can i get this piece (the cushioning rubber). It is the rubber piece with the bolt threads coming out the end and it has a hex-shaped ridge around the outside. My AC lines are just being held in place by zipties at the moment, but i dont want to leave them that way.

Does anyone know the part number of this piece so i can order it?
 

·
Registered
Joined
·
1,835 Posts
I got mine off when I installed the bar and my car is an early production '04. Of course I don't even use the bar anymore since all it did was rub against the rain seal and rattle. Plus people have shown that it doesn't really add much stiffness since the strut mounts are attached to the firewall.
 

·
Registered
Joined
·
13,608 Posts
The bracket is attached to the firewall with 2 screws. I unscrewed the first one and took it out.

I then loosened the second one, roated the bracket clockwise and re-torqued the screw.

I think I posted pictures of it on some thread, let me see if I can find it.
 

·
Registered
Joined
·
287 Posts
409industries said:
I think you guys may be missing the point of my post. I am looking to find a replacement rubber cushion. I ripped the original one in half...
I didn't use the bracket I just took it off and I don't see any problem if you don't have to use it.
 
1 - 5 of 5 Posts
Top