IW STi Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
185 Posts
Discussion Starter · #1 ·
Has anyone had any issues with their cruise control not working? Mine worked for the first 500 miles or so now I cant get it to activate. The Cruise Light comes on the dash but I can't get it to set.

One day I was trying to activate the Cruise and it wouldnt set, I used my toe to put some pressure behind the brake pedal and viola, it set. I was able to use it. The next time I tried to use it it didnt work with the pull up on the pedal trick. I adjusted the bolts that hold the brake pedal switch untill My brake lights almost didnt work at all. I tested it on my road and it didnt work, I put the switch back where it was.

I dont want to take this to the dealer because they will be driving the car and Im not into that at all! Any ideas?

Car: un-modified 2004 USDM WRX STi
 

·
Registered
Joined
·
1,468 Posts
see a dealer and tell us what they say/do.. Mention your concerns about them driving, and possibly stay there to see what they do, if u r that anal about your car..
Or find a mechanic u trust, slip him $20 and tell him to take care of your baby..
 

·
Registered
Joined
·
185 Posts
Discussion Starter · #3 ·
I admit it seems that I'm anal about the car, but my backwoods dealer has only sold 2 of these cars and the mechanics are complete ********, They would jump in with their greasy pants and tear up the road. I'll try to see them on Monday and see if I can be present when they take a look at the car.

edit: spelling
 
1 - 3 of 3 Posts
Top