IW STi Forum banner
1 - 7 of 7 Posts

· Registered
Joined
·
30 Posts
Discussion Starter · #1 ·
I drive an 04 STi.

First off, for some reason the little green warning light in the dash that means a light is out, is on. I noticed my license plate lights were out, so I replaced them today. The warning light was still on. So I thought maybe unplug the battery for a few and then plug it back in. No luck, the warning light is still on. I'm sure none of my lights are out but that little green light won't go away. Any ideas on that?

Second, my Subaru Security has been acting differently lately. When I arm it and disarm it, the lights on the outside of the car don't flash like they used to. Also, the security light in the dash used to go 'on, pause, on, pause, on, pause" and now it's doing some weird "blink blink pause, blink blink pause". I'm always freaking out now because the blinkers aren't flashing when I hit arm so I have to do it thrice to hear the honk to know it's actually armed. Any help with either of these would be much appreciated.
 

· Registered
Joined
·
10 Posts
bean said:
Second, my Subaru Security has been acting differently lately. When I arm it and disarm it, the lights on the outside of the car don't flash like they used to. Also, the security light in the dash used to go 'on, pause, on, pause, on, pause" and now it's doing some weird "blink blink pause, blink blink pause". I'm always freaking out now because the blinkers aren't flashing when I hit arm so I have to do it thrice to hear the honk to know it's actually armed. Any help with either of these would be much appreciated.
Sounds like valet mode.

Disarm your alarm, open the door, then press and hold the disarm button for 2 seconds. I think that should fix it.
 

· Registered
Joined
·
141 Posts
This post just helped me out...I don't know what I would do without this website...Thanks.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top