IW STi Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter · #1 ·
I have had my cobb ap, aps cold air, and aps 3.5 turbo back system on for about 5k now. Last week I installed a perrin turbo intake tube and now yesterday I got a check engine light for running to lean (checked it with the cobb ap) I cleared the check engine light and now on the way home just cruising along in 6th at like 55 the light came back on again? It has been with the same tank of gas so im hoping it was b/c of the gas? Any ideas out there would be great, thanks a lot in advanced.
 

·
Registered
Joined
·
145 Posts
Yea becuase if you are not tunned, it says right in the manual for the cobb to not use any intake but theres unless your tunned. Iam assuming that the inlet and cai are your problems
 

·
Premium Member
Joined
·
8,137 Posts
get tuned bro....
 

·
Premium Member
Joined
·
4,591 Posts
+1 for the leak. I had the same problem when I switched to my CAI. Had a leak around one of the clamps that wasn't seated right. +12345 for getting a tune.
 

·
Registered
Joined
·
35 Posts
Discussion Starter · #7 ·
thanks for the help guys, just trying to see what else I could do before dropping a couple hundred bucks for a tune, guess I will tell the wife that it is "needed" and cant be avoided :).
 

·
Registered
Joined
·
13,608 Posts
Take off the last modification you put on and see if that clears it up, or as everyone mentioned, get tuned!
 

·
Premium Member
Joined
·
4,120 Posts
Va06Sti said:
thanks for the help guys, just trying to see what else I could do before dropping a couple hundred bucks for a tune, guess I will tell the wife that it is "needed" and cant be avoided :).

well you can tell here this, running lean and continuing to do so will mean $7000 down the road for a new motor....:lol:
 

·
IWSTI Club Level 11ty
Joined
·
5,687 Posts
Va06Sti said:
thanks for the help guys, just trying to see what else I could do before dropping a couple hundred bucks for a tune, guess I will tell the wife that it is "needed" and cant be avoided :).
absolutely. tell here the motor will blow up if you don't get it tuned. you will benefit so much after the tune. both in engine 'safety', and performance.
 

·
Premium Member
Joined
·
5,283 Posts
I threw a check engine to lean once when I had my sti. I found out to be while i was wiping the engine down i slid one of the little hoses off the intake manifold. Popped it back on and wahlaa! You do need to get tuned, asap, but check all your hoses, might be simple fix for the mean time.
 

·
Registered
Joined
·
35 Posts
Discussion Starter · #12 ·
Thanks all, found that I had a hose that slipped off and the light has not came back on. I will be talking to the guys from agile automotive this weekend at th subaru challenge and setting up a tune date! Again thanks this board and everyone on it is a great help.
 
1 - 13 of 13 Posts
Top