IW STi Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
286 Posts
Discussion Starter · #1 ·
so i get in my car yesterday and the cd player kicked the bucket. i tried unplugging it and everything. the lights on the display that show the cd's and which one is playing and all that dont even light up. i cant eject them or play them. so does anyone have any ideas...is there a seperate fuse for this or anything?
 

·
Registered
Joined
·
13,608 Posts
Factory CD player or Aftermarket (if so, which brand/model)????
 

·
Registered
Joined
·
286 Posts
Discussion Starter · #3 ·
Peleg said:
Factory CD player or Aftermarket (if so, which brand/model)????
its the stocker!
 

·
Registered
Joined
·
13,608 Posts
ImprezivSTi04 said:
its the stocker!

04's didn't come with those. When did you buy the unit?

Should have a 12 month parts/labor warrenty on it.
 

·
Registered
Joined
·
286 Posts
Discussion Starter · #5 ·
Peleg said:
04's didn't come with those. When did you buy the unit?

Should have a 12 month parts/labor warrenty on it.
it was an option in 04...and i got it then
 

·
Registered
Joined
·
395 Posts
my '06 just did the same! I've got 6 CD's that are stuck in the damn thing and all I can listen to is the radio.
 

·
Registered
Joined
·
24 Posts
ImprezivSTi04 said:
its the stocker!
Sorry to hear about that. If your looking to get another stocker, I have one that I pulled out of my 05 after getting the alpine. I don't know what the going rate is for the stock unit but I'm willing to sell it for a fair price. I have it shrink wrapped up in my attic. Let me know. Peace.
 

·
Registered
Joined
·
2,452 Posts
slicknick112 said:
my '06 just did the same! I've got 6 CD's that are stuck in the damn thing and all I can listen to is the radio.
I had the same thing happen to my 05 GMC truck.... I took it out and opened it to find that one of the disc's was stuck so I popped it back into place. Its worked perfect ever sense.
 

·
Premium Member
Joined
·
8,137 Posts
see if hte dealer can fix it
 

·
Registered
Joined
·
373 Posts
This is a known problem on these stereos at least in the 06. I took mine to the dealer he said yea that happens. They ordered me a new one and traded them out one day over my lunch hour. The funny part is it had 6 CDs in it and I had to wait about a month for them to dissasemble the player at the manufacturer and ship all my discs back to the dealer. They called me one day and said they had them so I went and picked them up all individually in plastic sleves and in a nice little box. If the dealership gives you a hard time remind them that Subaru knows these things die being in our cars and that they just need to get you a new one.
 

·
Registered
Joined
·
216 Posts
The same exact thing happened to me about 3 weeks ago. I took it to a certain subaru dealer in Ithaca, NY and they replaced it under warranty. What sucks is that it appears as though someone took my car for a joy ride (9 extra miles on the odo to test a cd player, give me a break) - and if they were actually 'testing the cd player' for those 9 miles, they obviously didn't realize that the one they replaced it with doesn't work properly either. Audio drops out every minute or so on a brand new, spotless cd at different spots each time I play through the cd. There's also some static at random spots too. I've tried multiple new cds.

Bottom line, dealerships are whack. I'm thinking about getting a double din kenwood so I dont have to deal with this business (and because they're totally sweet)
 
1 - 11 of 11 Posts
Top