IW STi Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
125 Posts
Discussion Starter #1
Opitonal accesories worth getting

I installed my arc intake, ground mod, and an STi coupler(tired of the stock one slipping off) a couple of days ago. Also those are the only mods I have on the car. Didn't have time to test it out then, but took it out for a spin tonight.

First off I am basing my feeling that the car is running weird on the readings I am getting from my oil pressure guage, since the car is running pretty strong.
When the car was stock it would idle at about 2 bar and at cruising speed it would be at 6 bar, while it would go to 7 bar when I was pushing it. Tonight the oil pressure would idle at 2 bar, but when put in neutral to slow down to a stop, the pressure would drop off to 1.5 bar momentarily and then subsequently raise back to 2 bar when stopped. Is this normal?? If so y the sudden change in oil pressure when pushing clutch in to shift to neutral while slowing down.

Btw, didn't reset the ecu yet, could this be the problem??

Thanks

Wes
 

·
Registered
Joined
·
5,261 Posts
yes... resetting the ecu is kinda important. The ecu will normally adapt, but it'd be best if you reset it so its starting from scratch and then adapting to your new intake (rather then running stock and then trying to adapt). I dont know if that will fix your problems, but just check all your hoses and make sure the MAF is in correctly and you should be good to go.

Robert~
 

·
Registered
Joined
·
1,733 Posts
in reply to robert, i know for a fact if there is extra air getting into the motor after the MAF then you will crazy readings and the car will perform all crazy, speaken from personal expereince with my old rx7! So check that out, as for the ecu might as well try it, i still dont see what thats gonna do since there is always current running in the system even when you disconnect the battery! so see if you can swing by a dealer and check for any codes and have them reset it with the obdII scanner!?
 

·
Registered
Joined
·
125 Posts
Discussion Starter #4
I double checked all hoses and maf to make sure everything was on solid, after the install. Also I don't have ne codes to scan for since no cel or flashing cc was thrown. Also the car runs fine and builds boost faster and a little higher. Its just weird that the oil pressure is dipping below 2 bar now at low rpm's and then go back to 2 bar when stopped and idling. Does ne one else with a oil pressure guage experience this fluctuation of their oil pressure??
 

·
Registered
Joined
·
1,733 Posts
id tell ya but im in the process of installing my guages!
 

·
Registered
Joined
·
316 Posts
That doesn't sound bad. You changed the way the car draws air and it has to adapt to that. As long as you don't lose oil pressure under load. --Sin52

Your rpms must be dropping a little lower when you push the clutch in which would make the oil pressure lower.
 

·
Registered
Joined
·
125 Posts
Discussion Starter #8
sin52,

Thats exactly whats happening, I push clutch in and the oil pressure drops to 1.5 bar. But under load everything is normal.

Also biturbo, where exactly would I look into getting some real-time diagnosis without having to resort to the dealer??

I have yet to try resetting the ecu since the weathers so crappy here rite now, but will try that as soon as the sun come out.

Thanks for your help guys

Wes
 

·
Registered
Joined
·
39 Posts
It sounds as if the new intake causes a rich mixture off throttle. This would cause the idle to drop mommentarily as the RPM's fall quickly to the idle range. A small drop in RPM's at idle will cause an oil pressure drop. The ECU will pick the idle back up to normal range almost instantly, which should also raise the pressure back to the 2 Bar normal range.
 

·
Registered
Joined
·
125 Posts
Discussion Starter #11
I reset the ecu and it was dropping below 1.5 bar, but after driving it a bit the ecu seems to have adapted to the intake. I haven't really had a chance to drive it enough to tell if the ecu has adapted fully yet, but its holding a steady idle off throttle now. I think jeffsti hit it on the money. Thanks

Wes
 
1 - 11 of 11 Posts
Top