IW STi Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
According to the 04 STi service manual I have there seems to be a BIG mistake.

Please check this:
Body chapter in Security and Locks - Security System (SL-20)

In that page it shows the Security System as having a 18 wires for the connection. I have taken my security system out which is behind the glove box in the 04 STi. The connection is NOT 18 but instead a 40 pin connection using 37 wires.

Does anyone have the correct wiring diagram?

thanks,

-Ken (aka b0n3z)
 

·
Registered
Joined
·
10 Posts
Discussion Starter #3
Audio-Trader.com is a scam!

Exactly psycho - that pdf shows B93 as having only 18 wires. B93 is the connection for the security control module.

I wish I had a digital cam so I could snap a pick of the true wire harness and the alarm out of an STi.

thanks for the post - any else wanna comment on this Service Manual mistake?

-Ken (aka b0n3z)

psycho said:
This is not SL-20, but is straight from the electrical manual. Check here:

http://www.inspiredtech.com/subaru/securitysystem.pdf
 

·
Registered
Joined
·
10 Posts
Discussion Starter #4
Alright - I feel like a complete idiot. I was working on the STi again today and looked up further underneath the passenger side with the glove box out. I found the correct alarm system. I can't believe I was looking at the wrong harness and unit.

psycho - thanks for posting that info.

Can I go hide underneath a rock now?

-Ken (aka b0n3z)
 
1 - 4 of 4 Posts
Top