IW STi Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Exactly as the title states. Pretty brutal hey? Hopefully not with a 3rd party warranty I have at the dealership I bought it from, because well tf could I have done in 200km in the first drive, I didn't even use a full tank of gas XD. Its a 2013 with 115,000 kilometers on it, and I bought it with aftermarket parts installed, the things I saw was a bov, and a short ram intake, I used my cobb accessport from my ole 07 FXT as it works for the 13, and had seen it was tuned so i was pretty sure i would be good to drive to work then on the way home stop at a reputable tuner to get it checked out and make sure it was a good tune and allow me to use my cobb accessport as i didnt want to wipe the old tune and fuck something up most likely, because the parts on it. I'm near certain it's stock exhaust still, but the dealership had no real knowledge about it so I just took how it well it drove and it was a deal. I was very impressed when I test drove it, and really up until I died on the side of the road it was fucking sweet... long story short I got stranded 2 hours in between where I needed to be for work, and where the dealership is... and I hitch hiked back to work.... and spent already 950 dollars on towing to get it to a mechanic where I was told the best option would be to just take it to the dealership because the mechanic got it started and I guess it's knocking and squeeling now, and can't stay started, it was only up for about 5 seconds says the mechanic. So now I'm having it towed back to the dealership to find out diagnosis. They had all fluids changed, the car was inspected and passed of course, I wasn't driving it hard as I didn't even have it insured or registered, as I didn't exactly have the time to do so and I was still on a grace period, so I just threw my plate on from my 07 FXT I traded in. I checked the oil before I drove it and it looked fresh, maybe a bit over half an inch under the dipsticks full dot so I thought hey that should be great I'll check it when I fuel up for the first time and see what I'm looking at for possible oil burn... I'm almost certain I was about half a tank or a bit under and hadn't filled up yet. The car fax was pretty good to, had routine oil changes and only 1 collision report but didn't claim anything so it must have been pretty minor. I'm quite scared the warranty may for whatever reason not cover it, but I'm 99% sure it wasn't my fault, i didnt want to kill the car as i didnt have my accessport giving me numbers until i had it incorporated into its tune. I'm super hopeful it will cover it, as it's 24 month powertrain and electrical, if I didn't use it I would have had another 24 months of powertrain coverage. Just think this is probably one of the worst things that could almost possibly happen after buying any car... but idk if the warranty works out... maybe it's bad enough for a crate engine?? You can always dream right...
 

·
Registered
Joined
·
1,384 Posts
that sucks,

and i'm surprised your AP worked when it was from a different car/chassis. I would be sure NOT to mention that to the dealership you got it from. if they are anything like the ones we have in the US, they will say you tried to tune it and it's your fault.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #3 ·
Yeah it's horrible... yeah I'm going to just say it's from my Forester and I didn't try using it as I'm "pretty sure it doesn't work with this car" even though it does.... I only used it for code reading anyways I have nothing to hide. I'm just worried they'll find away to void the warranty over the existing aftermarket parts in the car...
 

·
Registered
Joined
·
1,384 Posts
Yeah it's horrible... yeah I'm going to just say it's from my Forester and I didn't try using it as I'm "pretty sure it doesn't work with this car" even though it does.... I only used it for code reading anyways I have nothing to hide. I'm just worried they'll find away to void the warranty over the existing aftermarket parts in the car...
again, remove the AP and dont mention it, at all.

if they sold you the car, with a warranty, that ALREADY had the aftermarket parts, they shouldnt be able to deny said warranty. it's not like you put them on.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #5 ·
Yeah the only shit thing is I left the accessport in my car, not plugged in or anything but it's in the passenger seat as I drove the car off the lot with the accessport in hand because I has left my fxt that day and took the ap. Hopefully they don't question it at all but I hope my word of it being from my Forester is enough. Yeah I'm just worried about the 1% chance it doesn't.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #6 ·
And the car broke down 2 hours away from me, so the tow company will be just taking it to the dealership for me and I won't be seeing the car until the diagnose what happened to it.
 

·
Registered
Joined
·
1,384 Posts
ahh, well in that case, if they ask about it, only then should you say anything. and say it's for your other car and designed for that ECU, and that it shouldnt work on this car, if they decide to plug it in and say it does work, ask if that was something they did to fix the issue you are having, and ask them to explain how it did/would have helped. note, they wouldnt be able to. basically just dont say you ever plugged it in, it just happened to be left in the car and it was for your other car. honestly i doubt that would be an issue.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #8 ·
Thanks for giving me some thoughts man I appreciate it. Even thought I'm damn near certain I can't be blamed and it will be covered, I'm the guy that sits there and worries about it lol I mean it was 20k I'd better hope it will be covered for the sake of my bank account.
 

·
Registered
Joined
·
1,384 Posts
Thanks for giving me some thoughts man I appreciate it. Even thought I'm damn near certain I can't be blamed and it will be covered, I'm the guy that sits there and worries about it lol I mean it was 20k I'd better hope it will be covered for the sake of my bank account.
idk how canada is, as i'm from the US, but if that happened here, it would be extremely hard for a dealership to not honor the warranty and i wouldnt think they would not fix the car. i'd imagine you'd get a new motor, and then, you got a used car with a new heart basically, without paying for the new heart aka motor lol. so honestly it may work out as a good thing, even though it's a headache now.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #10 ·
Fair enough, still very reassuring as finding people that have had this bad of luck seems to not be the easiest. And yeah I've been thinking about that, if they replace the engine I gain value on the car I'd think, even though I plan on keeping it in the long run but a new engine would be fuckin killer... I'm praying to God they don't try and rebuild it.
 

·
Registered
Joined
·
1,384 Posts
Fair enough, still very reassuring as finding people that have had this bad of luck seems to not be the easiest. And yeah I've been thinking about that, if they replace the engine I gain value on the car I'd think, even though I plan on keeping it in the long run but a new engine would be fuckin killer... I'm praying to God they don't try and rebuild it.
chances are, a dealership will replace the shortblock, as it's cheaper vs rebuilding it for them. although they may have a machine shop rebuild the heads, which unless the heads were severely damaged, isnt anything to worry about.
 

·
Registered
SWP 2012 GR Hatch
Joined
·
852 Posts
Yeah the only shit thing is I left the accessport in my car, not plugged in or anything but it's in the passenger seat as I drove the car off the lot with the accessport in hand because I has left my fxt that day and took the ap. Hopefully they don't question it at all but I hope my word of it being from my Forester is enough. Yeah I'm just worried about the 1% chance it doesn't.
"Oh that, that's from my old car I traded in" /Story.

Best of luck on this situation but you never plugged the accessport in because it's for a different car😉

If you can get a warranty shortblock you verywell could have just spent the best 950$ on a used car you ever have in your life.

When the new engine goes in, baby that thing!

I've got a 2012 w/ 136k and it doesn't burn a drop.
Full bolt on now, but here are some things I recommend:

  • When you start the car, let it warm up till 100F before moving
  • Don't get into boost until it's at operating temp for a sec.
  • Only fuel with Petro 94 unless you get a 91oct protune done... Even the 91 ACN tune isn't safe enough for our 91oct.
  • Don't 'get into it' under 3k RPM.
  • Oil changes every 5k with Motul X-cess or Shell Rotella.
  • Although you may be hesitant to do any mods, and I would at least wait till the engine is broken in (1k of easy driving, don't cruise at a constant RPM), look into an AOS, oil pickup/baffle, and cyl 4 cooling mod.

I'd take the BOV off because it doesn't serve any beneficial purpose (it's actually bad for the car) and make sure you get a proper Cobb on there meant for the car if you're going to run that intake.
I know a lot of people just unmarry the accessport before trading it in and don't care if it's bad for the car because it's not their problem anymore.
That verywell could be why it blew up, it was running lean from the intake on an OEM tune and wasn't having it.

These cars can be a bitch but you treat them right and they are super rewarding to drive.... especially in the winter.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #13 ·
All I've heard so far is "our impression is that the issues with your vehicle started after it was in your possession"... I forsee this getting ugly unfortunately.
 
1 - 13 of 13 Posts
Top