IW STi Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
1,706 Posts
Discussion Starter · #1 ·
Here's the problem.

I have a turbo back on the way and I wanted to port the wastegate before I install the turbo back and get it tune. I dont want to install the turboback and then get it ported. But I asked a shop around the area and they told me that the 05 STi don't get boost creep problems.

Just wanted to know if this is true for the 05 STi?

-Daniel
 

·
Registered
Joined
·
1,513 Posts
Does the turboback have a cat or not? If you do not have a cat you will mroe than likely have boost creep only when it gets cool outside or during the winter time. Of course this highly depends on the tune.
 

·
Registered
Joined
·
3 Posts
Ya I have an 05 with headers, uppipe, tbe without a cat and definetely have boost creep. The thing is 1st gear doesnt experience it, and if i max out every gear there is no problem. It only happens say when you are in 4th,5th, or 6th gear and at low rpm's and go wot, that is when i get it. I refuse to port the wastegate though, I am going to get engine management and change the wastegate duty cycles and that should fix it.
 

·
The Hoff Fan Club, member #001
Joined
·
9,936 Posts
^^^ thats what boost creep is, it happens when you floor it in the lower rpm in the upper gears. sometimes EM can fix it, and sometimes its a mechanical problem. its really a crap shoot.
 

·
Registered
Joined
·
1,706 Posts
Discussion Starter · #7 ·
damn....what are my options...

i heard sometimes tunes can't fix it, therefore i have to go for porting of wastegate or upgraded the turbo....maybe....external wastegate
 
1 - 7 of 7 Posts
Top