IW STi Forum banner

21 - 29 of 29 Posts

·
Registered
Joined
·
902 Posts
It would be absolutely ludicrous to buy anything or make any repair attempts without first ruling out the most likely suspect. Get a compression and leakdown test performed first.
 

·
Registered
Joined
·
1 Posts
Hey I have a 03 Subaru wrx with auto trans. And It smokes at idle. And it smell like brunt oil. This is my first Subaru so i dont know anything about these cars. and when ur driving on the freeway the smoke it bad Like a big fog. And if u drive a long ways it cleares up. But when u park it really smokes! So someone help me please.
 

·
Registered
Joined
·
70 Posts
Discussion Starter #26
So here is my final update on my problem! Te dealer said it was probably a cracked ringland. But this problem made another one, a connecting rod broke ecause my engine ran out of oil way to fast!!

So my car is still under the warrenty, but all 100% stock and im getting a new engine soon! Will have my car in a week or 2!!

Thx to Lachute Subaru for their great service!!!
 

·
Registered
Joined
·
179 Posts
Hi guys! Im having a problem with my STi recently.

I have Perrin recirc BOV, K&N drop in filter, catless downpipe, Magnaflow cat-back and Cobb 91 Stage 2 MAP.

always used some Gulf 5w/40 oil with OEM subaru filter.

All started with my car having problems while accelaration.

So I first re-mapped with my AP and kinda fixed the problem.

But it came back : / Did a oil change and I figured out that there were only 2 qts left on the 5 i did put in :O

I did install a new part too, the Greddy oil plug but I don't think my problem comes from this part -_-

So when I start-up my car, a lot of blue smoke goes out, and my acceleration is still bad :S

Anyone had this issues?

thanks for your time!
you call this stock in quebec?:rolleyes:

lucky you.got luck with the new engine.
 

·
Registered
Joined
·
126 Posts
oh good to know that the dealer is giving you a new engine. I actually just put my car 100% back to stock today too becus im bringing it into the dealer tmrw to get it checked out. Im not getting any smoke from exhaust or oil filler cap, but i did sense a significant loss of power and when i changed my oil today i got about 2.5 qts after 2,500 miles. not sure what it could be but i was curious to know if the dealer asked about any modded parts you had on it and what you told them? im kinda shitting bricks here hoping theres no problem and that they wont do anything about it if there is.
 
21 - 29 of 29 Posts
Top