IW STi Forum banner

81 - 100 of 360 Posts

·
Registered
Joined
·
1,048 Posts
Discussion Starter #81
Was running (tap) water with Amsoil Coolant Boost addative. Kept having weird cooling system issues (not overheating) where I kept pushing coolant out. THe system would build pressure even while sitting. Turns out, had some sort of chemical reaction...addative went from pink to white and started attacking all aluminum parts. The following pics are the garbage that was still coming out after multiple flushes...and I had to keep opening up the drain, as it would clog it. Reeked of sulfer/ammonia.

Radiator can always be replaced, just hoping block damage is negligible. Going back to Subaru coolant.



 

·
Registered
Joined
·
1,048 Posts
Discussion Starter #82
Cage split in half... Thought these axles were supposed to be good to 800hp?

Anyone know if I can buy the cage separately? Parts sites don't even show it.

 

·
Registered
Joined
·
1,048 Posts
Discussion Starter #83
Amsoil coolant additive catastrophically attacked the radiator after all. Went to top it off and it started seeping through the tubes.







 

·
Registered
Joined
·
1,048 Posts
Discussion Starter #86 (Edited)
If you haven't figured this out yet, I have no luck.

Put the factory radiator in so that I could actually get some miles on the car. Was roadtripping to my parents house (~360 miles) last weekend when, roughly 15 miles from their place, the engine lost power, started knocking/clanging and backfiring/sputtering. The engine would still run (barely) and couldn't move the car out of it's own way.

The knocking sounded like a rod hitting the cylinder wall but the sputtering says timing? I haven't had a chance to dig into it, mainly because I'm scared I just trashed a $15k engine in less than 1000 miles.

Oil temps were good. Oil pressure good (even after it started knocking). EGTs good. A/F good. Coolant tempt good. Oil level good (and oil still looked clean--only ~600 miles on it).

Car was close to hitting 10,000 miles...
 

·
Registered
Joined
·
806 Posts
If you haven't figured this out yet, I have no luck.

Put the factory radiator in so that I could actually get some miles on the car. Was roadtripping to my parents house (~360 miles) last weekend when, roughly 15 miles from their place, the engine lost power, started knocking/clanging and backfiring/sputtering. The engine would still run (barely) and couldn't move the car out of it's own way.

The knocking sounded like a rod hitting the cylinder wall but the sputtering says timing? I haven't had a chance to dig into it, mainly because I'm scared I just trashed a $15k engine in less than 1000 miles.

Oil temps were good. Oil pressure good (even after it started knocking). EGTs good. A/F good. Coolant tempt good. Oil level good (and oil still looked clean--only ~600 miles on it).

Car was close to hitting 10,000 miles...
Jeezus man :( Hopefully it isn't as bad as it seems :(:(
 

·
Registered
Joined
·
1,048 Posts
Discussion Starter #88
Crappy pics, as always :)

Got the engine out and on the engine stand (BY MYSELF) in 3 hours...not bad















EFFING Amsoil garbage made a mess of my entire engine...




That's where I left it and went farming...engine bars over and isn't making any noises. Two spark plugs were rusty and one burned through the insulator--doesn't explain the inability to maintain revs and knocking.

Was ecstatic to see the cams were spotless and buckets were only lightly "polished." That panic thread on NASIOC had me scared but it looks like WPC is the answer.
 

·
Registered
Joined
·
1,152 Posts
Fingers crossed for a fellow Illinoisan/Chicagoan. The only help I can offer is you ever need anything TIG welded LOL
 

·
Registered
Joined
·
582 Posts
Awesome, good on you for not giving up. I enjoy this journal, good luck on bring it back together.

Do you do your own tuning ?

S
 

·
Registered
Joined
·
1,048 Posts
Discussion Starter #92
Thanks guys... Tuning was going to be Boosted Performance Tuning - - only ended up with a base map, since I didn't get it running right (limp mode).

STi Addict... No thanks. I don't need someone else's bad luck compounding mine--world might implode.
 

·
Registered
Joined
·
1,048 Posts
Discussion Starter #93
Still haven't torn the car down... I did voluntary separation from work (going to be laying people off anyway) and will potentially have a few months off (full pay) to work on it.

That said I have been applying to new jobs and things are looking promising. If it works out, I'll have double pay checks for about 4 months, which will help get everything back together (and more).

Plans this winter include rewiring/cleaning up gauges and push button ignition. This will include wiring the gauge sensors into the factory engine harness and splicing them at the ECM (have TGV, air pump and evap sensors that I can steal wiring from).

I'll also start work on my air to water setup--cutting out the spare tire tub and sticking a radiator under the rear of the car, plus setting up tank, pump and lines... Then figuring out the air to water mounting.

Also, since I'll have time, I'd like to strip hubs, diff and other drive train components so that I can paint them proper... Disgusting to see everything rusting so badly on a car that doesn't see rain or snow.
 

·
Registered
Joined
·
2,904 Posts
Still haven't torn the car down... I did voluntary separation from work (going to be laying people off anyway) and will potentially have a few months off (full pay) to work on it.

That said I have been applying to new jobs and things are looking promising. If it works out, I'll have double pay checks for about 4 months, which will help get everything back together (and more).

Plans this winter include rewiring/cleaning up gauges and push button ignition. This will include wiring the gauge sensors into the factory engine harness and splicing them at the ECM (have TGV, air pump and evap sensors that I can steal wiring from).

I'll also start work on my air to water setup--cutting out the spare tire tub and sticking a radiator under the rear of the car, plus setting up tank, pump and lines... Then figuring out the air to water mounting.

Also, since I'll have time, I'd like to strip hubs, diff and other drive train components so that I can paint them proper... Disgusting to see everything rusting so badly on a car that doesn't see rain or snow.

I like what I hear!
 

·
Registered
Joined
·
1,048 Posts
Discussion Starter #95
Intake, exhaust and heads are off...again, pleasantly surprised how well the cams/buckets broke in.

Not seeing anything physically wrong (spun bearings, rod bent/broken, valves damaged/broken)....just a lot of soot/coking/not sure what the "orange" stuff is.















 

·
Registered
Joined
·
1,048 Posts
Discussion Starter #96
I've given Amsoil 2 months now, to make this right and they still haven't gotten anywhere...so it's time to start bringing this to the automotive community's attention...here are some more pictures of the garbage/destruction.







The list of parts I'm going to have to replace, is growing. Basically entirely new cooling system...again. Block and heads will be torn down so I can hot tank them.
 
81 - 100 of 360 Posts
Top