IW STi Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
154 Posts
Discussion Starter #1
If so, did you keep the stock muffler? I am wondering about two things (take a guess). What was the boost creep situation - did it reach fuel cut? Also, did you have to buy the CEL fix? I would assume that the cat would do it's job. This is on an otherwise stock car...
 

·
Registered
Joined
·
759 Posts
hayasa said:
If so, did you keep the stock muffler? I am wondering about two things (take a guess). What was the boost creep situation - did it reach fuel cut? Also, did you have to buy the CEL fix? I would assume that the cat would do it's job. This is on an otherwise stock car...
I have the TurboXS TBE with a high flow cat. I am using the TXS magnaflow muffler. I do have creep especially when very cold. I am having the waste gate ported soon. I had a fuel cut once when it was 9F{wind chill of -7F}. No CEL fix required for o2 sensor....I have had it on 6+ months with no problems.
 

·
Registered
Joined
·
133 Posts
V-1 user question

i have the stealthback exhaust on mine utilizing the stock STI muffler with the high flow cat. no boost creeps or cuts at all. No CEL.
 

·
Registered
Joined
·
154 Posts
Discussion Starter #4
Did you all have to use the long hangers or is that just for the muffler assembly?
 

·
Registered
Joined
·
219 Posts
I've had the TXS sleathback, w/ stock muffler, 3 weeks now.
I had boost creep (to fuel cut) once-the day after I installed it.

I was going 120MPH and running around 5500RPMs in 5th gear. I hadn't reset the ECU after I installed the exhuast and it was very cold (10 degrees F). Maybe it takes a day or two for the ECU to learn how to adjust boost w/ the new exhaust.

I haven't had any creep since, even driving hard up over 110; but I haven't gone over 115, as a precaution.

In my opinion, do it. If I have to keep it under 120 (potentially to avoid creep) to drop my 1/4 mile by a few tenths-I will.

But, I think now that my ECU has been reset, and once I get the SBC-id boost controller installed I won't have any creep (or very minimal) anyway. Guru seemed to think the same thing, when I spoke w/ him about my situation-he was very suprised I had any in the first place since I kept the stock muffler.

--UPDATE--
I went out today (50 degrees F). I ran hard all the way up to about 135-NO CREEP! It was either the ECU not being reset or the extreme cold. Moral of the story: W/ the TXS stealthback, operating during reasonable outside temperatures, boost creep is not an issue.
 

·
Registered
Joined
·
298 Posts
I also have the TXS set-up w/stock muffler. I haven't experienced any boost creep but i do get CEL but only during long cruise so i went for a mechanical fix (2 anti-fouling plugs screwed together). I'm on my 2nd Cat now because the first one was defective (loose catalyst inside) and had it replaced for free. Despite these problems i'm pretty happy with this set-up. I got it from WorldOne Performance and i had to mention this because customer service there is A+++.
 
1 - 6 of 6 Posts
Top