IW STi Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1
If radio reception is terrible with the factory antenna, has anybody tried something different? Maybe something small like the Honda S2000 antenna...or whatever?? I gotta be able to listen to sport talk every now and then!
 

·
Registered
Joined
·
2,468 Posts
clonegts posted this this a while ago. i'm waiting for someone else to try it first. :oops: it says it pulls in your favorite stations. i like bbc radio 4. :) seriously though, i'm going to be ticked if i have to install a visible antenna. i can't help but think that something is wrong with the antenna amplifier; as in it's not connected. the internal antenna works fine on my '00 outback wagon.
 

·
Registered
Joined
·
2,468 Posts
canadians. does your antenna pull in okay?? does *anyone* have an aftermarket radio that pulls in a good signal? i'm getting my 9815 installed today so i'll find out soon enough.
 

·
Registered
Joined
·
2,773 Posts
I'll be interested to hear your results with the 9815....it seems to be a favorite around here. (might have to change my choice now in the interest of being different ;) )
 

·
Registered
Joined
·
23 Posts
I have a 9815 installed. Been using it for a week now. Gotta say, love it.

As for the antenna in the STi, I get just as good of reception as I did with the extrernal antenna that came with my del Sol. I've even noticed better reception in "dead zone" areas than before.
 
1 - 5 of 5 Posts
Top