IW STi Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
226 Posts
Discussion Starter #1
Im getting ready for my e85 setup one part at a time install wise so its easier to chase issues if it occurs.parts for the build includes:aem fuel pump,iag fuel rails,id1050x injectors,smy fuel lines with an fittings,cobb ff sensor & fuel psi sensor,aeromotive adjustable fpr. I started with the fuel pump first and replaced the oem unit,after the install im experiencing little issues here and there.long crank after shut down at least few minutes,fuel stumble at times and a humming noise by the stock fuel lines about 2-3 seconds for first start up.im thinking about pulling the fuel pump basket and checking the o rings maybe not seated right during install.other than that the car feels responsive with few stumbles at times.any inputs from people here would be much appreciated before i go on with the build. im currently on stage 2
stock intake,tomei elh,grimmspeed catted limited dp,3 inch catback on brentuning etune.
 

·
Registered
Joined
·
495 Posts
When I installed my Walbro fuel pump I needed to buy aftermarket o rings as the ID on the stock O ring was too big for the Walbro. Using the stock o ring caused a number of hesitation and start up issued. I used a Viton - 203 (5/16 x 9/16 x 1/8) O rings and my issues went away. You may want to look into it.
 

·
Registered
Joined
·
226 Posts
Discussion Starter #5
Problem solved...AEM only provides 2 new o-rings so i missed one but there's a total of 4 all together in the fuel pump basket/hanger,i just reinstall what i have.

Sent from my LG-LS993 using Tapatalk
 
1 - 5 of 5 Posts
Top