IW STi Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
I’ve recently bought a 2012 wrx sti and it is in excellent condition other than the clear protective film that was put on the front bumber/hood, mirrors, and other high affected areas. The film is showing a white line on all of the edges. It doesn’t stand out too noticeably but the car is dark grey so I’d like to try to repair it if possible. Just wondering if anyone has any info on this situation or has been through this before.
 

·
Registered
Joined
·
3,133 Posts
pull that shit off.. the subaru paint is suck-ass and doesnt deserve to be protected anyway.. its probably cheaper to respray the car than to apply those absurd protectors.
 

·
Registered
Joined
·
110 Posts
I'm a huge fan of the protective films. I don't pay anyone to do it as I purchase the kits covering the areas I desire. I've installed nearly a dozen kits myself and they have saved many rock chips, which as enoxard has pointed out, is notorious on the less than stellar Subaru paint.



If it's only the edges, it's probably just wax build up that wasn't cleaned up well enough at the time it was applied. Take some Q-Tips or microfiber clothe, dipped in a light alcohol solution (like sub 40%), along the edges and they should clean up pretty good.



When you wax it, just take note of the edges as I also take the wipe up cloth along the edge with light pressure to get any in the spot.


Good luck and congrats on the new car!!
 
1 - 5 of 5 Posts
Top