IW STi Forum banner
21 - 30 of 30 Posts

· Registered
Joined
·
126 Posts
Your idle speed is what it should be

Can you confirm your afr learning 3 is reading -50% in the cvs file ?
This is one of the short term fueling trims that makes adjustments based on if your cat is good or not. I'm not sure if it would be related to surging but it shouldn't read -50%
Font Rectangle Slope Handwriting Water


I noticed your exhaust retard angles isnt line with the other vvt's; Im not sure if this is normal but i could check on my car
Font Electric blue Display device Circle Screenshot
 

· Registered
Joined
·
19 Posts
Discussion Starter · #24 ·
alright - update

The exhaust retard angle was odd, especially since it started at 13 and then went down to 3.
I unplugged the battery again - took it for a drive, and low and behold the P0017 came back.

At this point - with a swapped sensor and still having the error, I took the timing belt off, made sure everything was aligned, and put it back together.

I swore that the passenger side exhaust cam lined up, but it was off by 1 tooth.


if you have read up to this point I am dumb.


Here is a warm idle log


AF learning 3 isn't at -50 anymore, and the vvt retard angle right is now... at 0.


Here is a short cruise around my neighborhood :

 

· Registered
Joined
·
126 Posts
Would recommend a boost test for this. There's some good videos on YouTube for it.

One thing not all of them show is blocking off the path ways for the pcv system. It's good practice not to pressurize the crankcase. You'll still get pressure from air going by the rings. But it will be a lot less. Have your oil cap off for this test too

No need to be popping seals or anything

Sent from my SM-S901W using Tapatalk
 

· Registered
Joined
·
19 Posts
Discussion Starter · #28 ·
Did this last night and found some interesting spots.

I had a tiny leak coming from the passenger side gasket between the TGV and the Intake manifold.

This took me a while to resolve due to the "easy access" of that area :D especially with an AOS from Crawford.

Going to come up with some sort of poor man's stethoscope and try it again to see what I find.
 

· Registered
Joined
·
19 Posts
Discussion Starter · #30 ·
Wow, yep - reread post 24 from me lol, I was just listening and putting my fingers all over.

I have an avcs oil line leaking at the back banjo bolt on the passenger side I need to figure out so, once I get it back together again.. soap and water.
 
21 - 30 of 30 Posts
Top